Ceph health warning - all OSDs are running pacific or later but require_osd_release < pacific

Mike85

Member
Jun 12, 2020
22
3
8
37
Hi,

this morning I have updated our pve Cluster inkl. ceph (16.2.7 > 16.2.9).
Ceph is working fine again but I do have a OSD Health-Warning (see below), what can I do (cluster Status is fine).

1656047421729.png


1656047437369.png


1656047467411.png


# ceph health detail
HEALTH_WARN all OSDs are running pacific or later but require_osd_release < pacific
[WRN] OSD_UPGRADE_FINISHED: all OSDs are running pacific or later but require_osd_release < pacific
all OSDs are running pacific or later but require_osd_release < pacific

# ceph versions
{
"mon": {
"ceph version 16.2.9 (a569859f5e07da0c4c39da81d5fb5675cd95da49) pacific (stable)": 3
},
"mgr": {
"ceph version 16.2.9 (a569859f5e07da0c4c39da81d5fb5675cd95da49) pacific (stable)": 3
},
"osd": {
"ceph version 16.2.9 (a569859f5e07da0c4c39da81d5fb5675cd95da49) pacific (stable)": 24
},
"mds": {
"ceph version 16.2.9 (a569859f5e07da0c4c39da81d5fb5675cd95da49) pacific (stable)": 3
},
"overall": {
"ceph version 16.2.9 (a569859f5e07da0c4c39da81d5fb5675cd95da49) pacific (stable)": 33
}
}
 
Last edited:

Mike85

Member
Jun 12, 2020
22
3
8
37
Thanks a lot it worked:

1656048543625.png

I thought it would not be needed because I just run a minor update not an upgrade to an higher Ceph release.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!