CentOS Container no IPv6 Route

zille

New Member
Sep 30, 2019
3
0
1
24
Hello,

I'm not sure whether I've found a bug or if I am doing something wrong.
I have a CentOS 7 container on PVE 6.0-7 and when entering a /80 IPv6 address and fe80::1 as the gateway, there will be no default route in the container for IPv6.
Upon entering a gateway within the /80 address range, a default route is created.

Basically the file /etc/sysconfig/network-scripts/route-eth0 won't be touched by PVE, no matter what you insert as a default gateway.
 

Richard

Proxmox Staff Member
Staff member
Mar 6, 2015
799
32
48
Austria
Hello,

I'm not sure whether I've found a bug or if I am doing something wrong.
I have a CentOS 7 container on PVE 6.0-7 and when entering a /80 IPv6 address and fe80::1 as the gateway, there will be no default route in the container for IPv6.
Upon entering a gateway within the /80 address range, a default route is created.

Basically the file /etc/sysconfig/network-scripts/route-eth0 won't be touched by PVE, no matter what you insert as a default gateway.
Bug (see https://bugzilla.proxmox.com/show_bug.cgi?id=2406) - thank you for discovering.
 
  • Like
Reactions: zille

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!