Centos 6.0 (centos-6-default_20161207) container no console after yum update


Active Member
Aug 14, 2019

I have a number of containers and vms which all work fine.

However if I create a container using the built in centos6 template centos-6-default_20161207_amd64.tar.xz

On first install it works fine and I can start / stop the container with no problems.

If I do a yum update and install all after restarting the container I no longer get a console - I have left for 5 / 10 minutes and nothing.

I have use pct enter <id> and I can enter the container fine. The networking seems to be fine as I can ping ip addresses.

If I try and debug starting the container I get the following

lxc-start -n 111 -F -l DEBUG -o /lxc-111.log
init: rcS main process (32) killed by TERM signal
iptables: No config file. [WARNING]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... done.
[ OK ]
Starting system logger: [ OK ]
Mounting filesystems: [ OK ]

I have attached the log file.

To clarify I have tested this a number of times with a fresh install of centos-6-default_20161207 and I get the same issue each time after updating centos.

any ideas? or anything else I can do to debug it?



  • lxc-111.log
    38.5 KB · Views: 1
interestingly I can also ssh in remotely to the container from another machine.

so it appers just the proxmox console seems to be broken for it, I have tried vnc/spice and xterm - same result.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!