[SOLVED] Can't use shell after reboot after I installed Proxmox new

Jun 17, 2021
14
1
8
43
Hello, somehow my previous post is gone so another try:

after some problems with an upgrade from 7 to 8 I decided to reinstall an restore all vms from the backup. Everything went well untill I rebooted the new Proxmox machine. Now I cannot log on anymore. If I try to log on from the web ui I can see only this:

Linux Europa 6.2.16-3-pve #1 SMP PREEMPT_DYNAMIC PVE 6.2.16-3 (2023-06-17T05:58Z) x86_64 The programs included with the Debian GNU/Linux system are free software; the exact distribution terms for each program are described in the individual files in /usr/share/doc/*/copyright. Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law. Last login: Tue Jul 18 15:58:15 CEST 2023 on tty1 Cannot execute exit: No such file or directory

- ssh does not work, I think it's the same error but the connection gets closed
- kvm remote console does not work, it just does not allow log in
- I can start vms from the webinterface
- I changed the shell from bash to zsh (which I installed before) in /etc/passwd file
- switch to an older Kernel does not help

Any sugestions?

Thanks
André
 
I found the issue. in /etc/passwd the shell for the root user was set to "exit". I have no Idea how and when this happend but I'm able to log in again.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!