[SOLVED] Can't upload any more iso files after I did my ubuntu


New Member
Nov 9, 2023
Hey everyone hope all is well. I just started proxmox this week and I am very excited. I did run into an issue where I can't download another iso file. I tried Windows 11 and Fedora and still no luck.

This is what is going on it, freezes up.

Please help.

Hi tacolover,

Welcome to the forums! I'm just as excited about Proxmox, and perhaps even more after using it longer.

(...) I can't download another iso file.
What are you trying to do? The screenshot says "Upload", is it the one you intended to post?

I don't recognize the popup window. In which area of Proxmox are you doing this?
Hi wbk,

So I am trying to upload more iso files like Windows 11, and other os.
But for some reason when I try to upload a iso file, it doesn’t upload. :(

I was able to get ubuntu iso but that's it.


  • Screenshot 2023-11-09 at 6.22.56 PM.png
    Screenshot 2023-11-09 at 6.22.56 PM.png
    56.5 KB · Views: 8
So when I upload the window iso file it gets stuck or doesn’t download.

I even tried another Ubuntu file and it gets stuck as well.


  • Screenshot 2023-11-09 at 6.25.37 PM.png
    Screenshot 2023-11-09 at 6.25.37 PM.png
    168.6 KB · Views: 6
I can't even get Debian iso file to upload


  • Screenshot 2023-11-09 at 6.54.59 PM.png
    Screenshot 2023-11-09 at 6.54.59 PM.png
    161.9 KB · Views: 4
Could you try downloading a container template?

If you go to "CT Templates", just under "ISO Images", there is also the option "Upload" and "Download from URL" like under ISO's, but there is a button "Templates" as well.

Can you download Ubuntu (for example) there? The benefit is that you'll get some task output on screen which helps figuring out the cause if it does not not work. In the screenshot below I downloaded the Alpine template (because it is very small) :


I also uploaded a random zipfile, to see what in kind of task log it results. Luckily, it returned an error.


What does your task log show? It's at the bottom of the screen, double click tiny arrow in the middle to show if hidden, or search for the tasks somewhere at the bottom of your tree of properties of your node (just above 'Subscription', in my case) :

oh cool, I didn't know that.
So I download debian and it was it able to download.

Let me see if I can upload it


  • Screenshot 2023-11-09 at 7.28.59 PM.png
    Screenshot 2023-11-09 at 7.28.59 PM.png
    380.4 KB · Views: 4
Hi wbk, I just reset my server.
After the reset, everything started to work again.
I am now able to download vm iso files on the server again.

Thank you for the assistance.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!