[SOLVED] Can't start VM's

rauppe31

New Member
Mar 26, 2013
21
1
3
Hello

I can't start any KVM-VM's.
When I run
Code:
qm start 100
The following Error is showing:

Code:
bridge 'vmbr0' does not exist
/var/lib/qemu-server/pve-bridge: could not launch network script
kvm: -netdev type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge: Device 'tap' could not be initialized
start failed: command '/usr/bin/kvm -id 100 -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -vnc unix:/var/run/qemu-server/100.vnc,x509,password -pidfile /var/run/qemu-server/100.pid -daemonize -name test -smp 'sockets=1,cores=1' -nodefaults -boot 'menu=on' -vga cirrus -k en-us -m 512 -cpuunits 1000 -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -drive 'file=/var/lib/vz/template/iso/debian-6.0.7-amd64-netinst.iso,if=none,id=drive-ide2,media=cdrom,aio=native' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,aio=native,cache=none' -device 'ide-hd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge' -device 'e1000,mac=CE:40:3F:79:83:D8,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300'' failed: exit code 1
What can I do?
 
Last edited:

spirit

Well-Known Member
Apr 2, 2010
3,522
156
63
www.odiso.com
Hello

I can't start any KVM-VM's.
When I run
Code:
qm start 100
The following Error is showing:

Code:
bridge 'vmbr0' does not exist
/var/lib/qemu-server/pve-bridge: could not launch network script
kvm: -netdev type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge: Device 'tap' could not be initialized
start failed: command '/usr/bin/kvm -id 100 -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -vnc unix:/var/run/qemu-server/100.vnc,x509,password -pidfile /var/run/qemu-server/100.pid -daemonize -name test -smp 'sockets=1,cores=1' -nodefaults -boot 'menu=on' -vga cirrus -k en-us -m 512 -cpuunits 1000 -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -drive 'file=/var/lib/vz/template/iso/debian-6.0.7-amd64-netinst.iso,if=none,id=drive-ide2,media=cdrom,aio=native' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/images/100/vm-100-disk-1.qcow2,if=none,id=drive-ide0,aio=native,cache=none' -device 'ide-hd,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge' -device 'e1000,mac=CE:40:3F:79:83:D8,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300'' failed: exit code 1
What can I do?
Seem that you don't have a vmbr0 bridge in your network config.

can you post your /etc/network/interfaces ?
 

rauppe31

New Member
Mar 26, 2013
21
1
3
Seem that you don't have a vmbr0 bridge in your network config.

can you post your /etc/network/interfaces ?
This is my /etc/network/interfaces:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.121.60
        netmask 255.255.255.0
        network 192.168.121.0
        broadcast 192.168.121.255
        gateway 192.168.121.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.121.254
        dns-search fritz.box
 

spirit

Well-Known Member
Apr 2, 2010
3,522
156
63
www.odiso.com
This is my /etc/network/interfaces:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.121.60
        netmask 255.255.255.0
        network 192.168.121.0
        broadcast 192.168.121.255
        gateway 192.168.121.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.121.254
        dns-search fritz.box
So you have installed proxmox manually on top of a debian ?

you need to have a setup like this:


auto vmbr0
iface vmbr0 inet static
address 192.168.121.60
netmask 255.255.255.0
network 192.168.121.0
broadcast 192.168.121.255
gateway 192.168.121.254
bridge_ports eth0
bridge_stp off
bridge_fd 0
 

rauppe31

New Member
Mar 26, 2013
21
1
3
So you have installed proxmox manually on top of a debian ?
Yes.

you need to have a setup like this:


auto vmbr0
iface vmbr0 inet static
address 192.168.121.60
netmask 255.255.255.0
network 192.168.121.0
broadcast 192.168.121.255
gateway 192.168.121.254
bridge_ports eth0
bridge_stp off
bridge_fd 0
Ok, I have added this text to my /etc/network/interfaces and the VM's are now running. Thank you!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!