[SOLVED] Cant restore container.

HenryTheTech

Active Member
May 20, 2018
54
3
28
53
Doesn't matter where I attempt to restore it. Gives me this error every time.

Code:
TASK ERROR: unable to detect disk size - please specify mp2 (size)

Config:


Code:
arch: amd64
cores: 8
hostname: uni-plx-sync
memory: 4096
mp0: torrent:subvol-123-disk-1,mp=/media/torrent,size=400G
mp1: CQFsync:subvol-123-disk-1,mp=/media/CQFsync,backup=1,size=5G
mp2: hsync:subvol-123-disk-1,mp=/media/hsync
net0: name=eth0,bridge=vmbr0,hwaddr=5E:81:2D:71:C8:CC,ip=dhcp,type=veth
onboot: 0
ostype: debian
rootfs: unifi:subvol-123-disk-1,size=130G
swap: 1024
 
Did you add mp2 manually? The size parameter is missing in the config file.
For example,
Code:
mp0: torrent:subvol-123-disk-1,mp=/media/torrent,size=400G

But mp2 has no defined size. Try adding a size parameter (let's say 25GB), like for example:
Code:
mp2: hsync:subvol-123-disk-1,mp=/media/hsync,size=25G

After making the change in config, try to back up and restore again.
 
Last edited:
  • Like
Reactions: HenryTheTech
Did you add mp2 manually? The size parameter is missing in the config file.
For example,
Code:
mp0: torrent:subvol-123-disk-1,mp=/media/torrent,size=400G

But mp2 has no defined size. Try adding a size parameter (let's say 25GB), like for example:
Code:
mp2: hsync:subvol-123-disk-1,mp=/media/hsync,size=25G

After making the change in config, try to back up and restore again.


I only have the dumpfile so I wont be able to restore in order to backup again. But thanks for the heads up, I have no idea how that parameter got lost... I'll watch that doesn't happen in my next backups.

Thanks
 
Ok I have found what I believe is the conf file in my tar.lzo backup, and I made the correction you suggested...

Code:
/etc/vzdump/pct.conf

But now I am having a hard time re-creating the archive, I have tried

Code:
tar -cfvz /tmp/vzdump-lxc-123-2018_12_31-13_30_08.tar.lzo ./*

and

Code:
tar -cfv ./* | lzop > /tmp/vzdump-lxc-123-2018_12_31-13_30_08.tar.lzo

Sorry for my noobish questions. I understand if this is too much.
 
the `f` flag in a tar invocation needs the archive name as first argument:
`tar --lzop -cvf /tmp/vzdump-lxc-123-2018_12_31-13_30_08.tar.lzo ./*`
or
`tar -cv ./* | lzop > /tmp/vzdump-lxc-123-2018_12_31-13_30_08.tar.lzo`

should probably work.
 
  • Like
Reactions: HenryTheTech
You can also restore via CLI ('pct restore') and explicitly set --mp2 and add ,size=<DiskSize> (see 'man pct'). It should be set in your container then and new backups should include it.

EDIT: Seems like --rootfs and every mount point is required on the command line. You can use the shorthand --rootfs <storage>:<size> and --mp0 <storage>:<size> (with optional ,mp= and other settings).
 
Last edited by a moderator:
  • Like
Reactions: HenryTheTech
Solved!

Somehow the mountpoint size parameter was erased in the config file buried in the tar.lzop container backup:

Code:
/etc/vzdump/pct.conf

I then added the line that oguz suggested to the config and then used
Code:
tar --lzop -cvf /containername.tar.lzop  <container root>


Then I just restored in the gui and its back online. Thank you all for your help.
Amazing.
 
Glad the issue got resolved! Please mark the Thread as SOLVED - so that others know what to expect - Thanks!
 
  • Like
Reactions: HenryTheTech

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!