[SOLVED] Can't query current.cvd.clamav.net


Renowned Member
Dec 18, 2014

after upgrading to PMG 6.0 from PMG 5.2 via apt I get this when trying to update ClamAV:
WARNING: Can't query current.cvd.clamav.net
WARNING: Invalid DNS reply. Falling back to HTTP mode.
Reading CVD header (main.cvd): WARNING: Can't get information about database.clamav.net: Temporary failure in name resolution
WARNING: Can't read main.cvd header from database.clamav.net (IP: )

On the upgrade process I chose "use the version of the maintainer" instead of keeping the old config file.


hello, DNS should be working as I can reach the apt-repository. Regards
  • Like
Reactions: Afox
Indeed it was the apparmor and using
apt remove apparmor

fixed that issue. Thank you guys (also for making this software).


Glad that your issue is resolved and thanks for upgrading!

Please mark the thread as 'SOLVED' so that others know that they might find a solution here.
I've installed a new proxmox 6 host. it resolves DNS fine. for a centos CT I selected to use the host's DNS. This created a good /etc/resolv.conf on the CT. But DNS is not resolving on the CT. I checked my host and it does have apparmor. So, I attempted to remove it and got this warning, not certain if I should continue or not

W: (pve-apt-hook) !! WARNING !!

W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!

W: (pve-apt-hook)

W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command

W: (pve-apt-hook) touch '/please-remove-proxmox-ve'

W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package

W: (pve-apt-hook) and repeat your apt invocation.

W: (pve-apt-hook)

W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify

W: (pve-apt-hook) - your APT repository settings

W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade your system

E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)

E: Failure running script /usr/share/proxmox-ve/pve-apt-hook
Probably wrong forum - the issue described here is about Proxmox Mailgateway - not PVE (Proxmox Virtual Environment)!
PVE definitely needs apparmor (for container isolation) - do not uninstall apparmor on PVE.

I hope this helps!
I'm having the same problem ... And I already verified that the apparmor is not installed ...

Somebody else?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!