[SOLVED] Cant install Mellanox Driver

Discussion in 'Proxmox VE: Networking and Firewall' started by Younex, Dec 4, 2018.

  1. Younex

    Younex Member

    Joined:
    Jan 30, 2018
    Messages:
    33
    Likes Received:
    3
    Hi,

    i struggle to complete the installation of the mellanox driver (MLNX_OFED) (http://www.mellanox.com/page/products_dyn?product_family=26)

    When i start the installation process with the included script "mlnxofedinstall"
    It shows:
    ##############
    ...

    Do you want to continue?[y/N]:y

    Checking SW Requirements...
    Removing old packages...
    ##############

    And freeze at this point.

    Anyone else faced the same problem or solve it?
    I´m on a new fresh proxmox installation with latest updates (5.2-12).

    Thank you!
     
  2. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    1,741
    Likes Received:
    151
    Due to dependencies it wants to remove proxmox packages.

    If you only need the driver module, that is already included in the 4.15 kernel.

    Well, this is already old. ;):D
    https://forum.proxmox.com/threads/proxmox-ve-5-3-released.49423/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Younex

    Younex Member

    Joined:
    Jan 30, 2018
    Messages:
    33
    Likes Received:
    3
    Ha! i posted just when you released it!

    Thank you, both for the answer and the release.

    Finally i fixed the problem with modifying the installer script with commenting the deinstallation routine which was for first installation not necessary in my view - just in case somebody else run into this problem.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice