Can't install linux-headers

damarges

New Member
Jul 25, 2022
27
2
3
39
Bad Kreuznach, Germany
Tried using apt install linux-headers-$(uname -r) but doesn't work out. No headers available?

Code:
root@pve:/tmp# apt install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package linux-headers-6.2.16-14-pve
E: Couldn't find any package by glob 'linux-headers-6.2.16-14-pve'

Tried to install nvidia-driver after downloading it from nvidia.com but it requires the appropiate headers. I want to use my gpu for transcoding stuff on the host.
Can anybody help me what I am not understanding here?

Thank you
 
Like all the other threads about problems with installing kernel header:; install pve-headers-6.2.16-14-pve instead of linux-headers-6.2.16-14-pve, as PVE uses its own kernel.
 
  • Like
Reactions: damarges

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!