Can't get PBS to work with other user than root@pam

Andreas Piening

Well-Known Member
Mar 11, 2017
I'm on PBS 2.3-1 and I've successfully created a storage with the type Proxmox Backup Server on a PVE 7.3-3 host and I can do backups with the user root@pam.

When I create an additional user and permit Admin privileges for this user for a namespace within my datastore, I can still add the storage on my PVE node without an error. However, the icon next to the storage symbol which indicated the storage utilization is missing. And when I click on the storage entry and select Backups, I get a small gray overlay box with the message Connection error in the middle of the pane. Creating backups doesn't work either.

I've tried a few things but I just can't get the connection working with any other user than root@pam. I don't get meaningful error messages so that I can understand what is missing or what exactly went wrong.
can you post the permission settings of the pbs user as well as the storage config of pve ?
Hi @dcsapak,

the permission settings of the pbs-user are:

The storage config on the PVE host looks like this:
pbs: test_pbs
        datastore backup
        content backup
        fingerprint xx:yy:zz...
        namespace test
        prune-backups keep-all=1
        username test@pbs
i can see that the usage statistics does not work, but thats ok because the user simply does not have the rights to read that from the datastore (that cannot be shown per namespace)

but when i created such a user and added the storage to pve i could make/list backups without issues...

can you maybe post the exact error you get and the pve & pbs syslogs from that time?
I found an error message saying that the required permission is missing. After checking that the permission is still there like I had set it previously I created another test user and readded the storage config on the PVE host: This time it worked.
As I found no difference between the two users, other than username and different namespace, I decided to reset the password of my previous test user and then it also worked.

I used a randomly created password with all sorts of special characters before, it seems to me that this caused the issue. With a random password with upper- and lowercase letters with numbers and a subset of special characters I have no issues so far.
  • Like
Reactions: dcsapak


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!