Can't add application with apt install on container


New Member
Oct 28, 2023

For whatever reason, in a lxc container in proxmox I can’t find any applications via:

“apt search anything”. Anything is ANY application I try.

Here’s the output:

root@ffmpeg ~# apt install ffmpeg
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package ffmpeg
root@ffmpeg ~#

Yet, at the console at the top node (proxmox) I can find it. That is, “apt install ffmpeg” comes back with a list.
ffmpeg is JUST an example.

What gives?


I did an “apt update” followed by a “apt upgrade”. It updated many packages.
I then did a “apt install ffmpeg” and it WORKED!!

Not exactly sure what this did but it worked.
I suppose a best practice is to always do “apt update/upgrade” when you first run an install. I know this but forgot this time.




The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!