can't access with Container_IP:9080 or any other port

jluc2808

New Member
Mar 22, 2019
16
0
1
68
hello,
i run the last proxmox 5.3 on a x86 machin (core2duo 8500, 4Go Ram, wired ethernet, DD SATA: 156Go)
i just installed a new CT using debian-9.0-standard_9.5-1_amd64.tar.gz and after a successfull start i have sucessfully installed jeedom package from
https ://raw.githubusercontent.com /jeedom/core/master/install/install.sh
all the section and part have ran with successfull report

i have restarted the CT (as asked at the end of the installation) and get the CT running well

BUT: i can't connect to any apache2 web service using either the CT-name or IP address -
my CT is configured with ID: net0
Name eth0
bridge : vmbr0
Firewall : No
MAC adress: xxxxxx
IP address: dhcp (i find the IP address using ip -s -c -h a)

what is wrong ?
thanks for some help
best regards
jean-luc
 
Are the services running properly?

Code:
systemctl status apache2
journalctl -b -u apache2

Can you post your container config as well?

Code:
pct config CTID
 
return from systemctl status apache2
Code:
pache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/apache2.service.d
           `-privatetmp.conf
   Active: active (running) since Fri 2019-03-22 08:53:03 UTC; 2h 15min ago
  Process: 222 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 499 (apache2)
    Tasks: 6 (limit: 4915)
   CGroup: /system.slice/apache2.service
           |-499 /usr/sbin/apache2 -k start
           |-532 /usr/sbin/apache2 -k start
           |-533 /usr/sbin/apache2 -k start
           |-534 /usr/sbin/apache2 -k start
           |-535 /usr/sbin/apache2 -k start
           `-536 /usr/sbin/apache2 -k start

Mar 22 08:52:59 docker-debian systemd[1]: Starting The Apache HTTP Server...
Mar 22 08:52:59 docker-debian apachectl[222]: /usr/sbin/apachectl: 99: ulimit: error setting limit (Operation not permitted)
Mar 22 08:52:59 docker-debian apachectl[222]: Setting ulimit failed. See README.Debian for more information.
Mar 22 08:53:03 docker-debian systemd[1]: Started The Apache HTTP Server.

return from journalctl -b -u apache2
Code:
-- Logs begin at Fri 2019-03-22 08:47:58 UTC, end at Fri 2019-03-22 11:10:03 UTC. --
Mar 22 08:52:59 docker-debian systemd[1]: apache2.service: Failed to reset devices.list: Operation not permitted
Mar 22 08:52:59 docker-debian systemd[1]: apache2.service: Failed to set invocation ID on control group /system.slice/apache2.service, ignoring: Operat
Mar 22 08:52:59 docker-debian systemd[1]: Starting The Apache HTTP Server...
Mar 22 08:52:59 docker-debian apachectl[222]: /usr/sbin/apachectl: 99: ulimit: error setting limit (Operation not permitted)
Mar 22 08:52:59 docker-debian apachectl[222]: Setting ulimit failed. See README.Debian for more information.
Mar 22 08:53:03 docker-debian systemd[1]: Started The Apache HTTP Server.

resultat PCT config 101
Code:
arch: amd64
cores: 1
hostname: docker-debian
memory: 1024
net0: name=eth0,bridge=vmbr0,hwaddr=76;DC:82:DE:AB:22,ip=dhcp,type=veth
postype: debian
rootfs: local-lvm:vm-101-disk-0,size=8G
swap: 512
unprililedged: 1
 
Looks like apache is working as expected. The ulimit error can be ignored.

I guess you're using docker on this CT? For nested containerization (LXC + docker or LXC + systemd nspawn etc.) you should enable the "Nesting" feature for the CT. This can be done in the GUI under container options or you can add
Code:
features: nesting=1

to the container config.

Also, please check if you have a firewall enabled (on Proxmox settings or in the container itself). Maybe that's why you can't reach the services ;)

If not, the output from
Code:
ss -l
can be also useful in debugging any issues with services.
 
the result is the same using container_IP:9080 but
if i start with just container_IP no port it's OK
unbelievable !!!!

thanks a lot
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!