[SOLVED] Cannot use LXC recovered from source - all files belong to nobody.nogroup

cmonty14

Active Member
Mar 4, 2014
338
4
38
Hello,

I had faced a disaster affecting the root partition of Proxmox VE.
Of course I have no backup, shame on me.
However, I have stored and KVM virtual disk (qcow2) and any LXC virtual disk (raw) on a seperate drive (SSD) that is not affected by the disaster.

So, I managed to install Proxmox VE 6.3 on a new disk, and now I'm rebuilding every KVM and LXC instance.
I was successfull with a KVM instance running Win10 and 2 LXC instances.

But now I'm failing with another LXC instance hosting a mailserver application (mailcow).

What did I do in order to recover the virtual instances?
1. Creating a new CT using LVM (not LVM thin)
2. Configuring storage to use my working SSD
3. Migrate the newly build virtual disk from LVM to SSD
4. Copy the old raw file over the newly created virtual disk raw file
5. Start LXC

As said, this procedure worked with 2 LXC instances, and now it fails with another LXC instance.
The error message when entering the started LXC instance is:
Code:
root@pc4-pve:~
$ pct enter 104
bash: /root/.bashrc: Permission denied

Furthermore I have identified that any directory has owner nobody.nogroup.
Code:
root@vm104-mail:~# ls -l /var/
total 44
drwxr-xr-x+  2 nobody nogroup 4096 Mar 10 07:21 backups
drwxr-xr-x+  9 nobody nogroup 4096 Mar  9  2017 cache
drwxr-xr-x+ 45 nobody nogroup 4096 Jan 13  2017 lib
drwxrwsr-x+  2 nobody nogroup 4096 May  4  2015 local
lrwxrwxrwx   1 nobody nogroup    9 Jun 30  2015 lock -> /run/lock
drwxr-xr-x+ 10 nobody nogroup 4096 Mar 10 07:21 log
drwxrwsr-x+  2 nobody nogroup 4096 Mar 11 00:00 mail
drwxr-xr-x+  2 nobody nogroup 4096 Jun 30  2015 opt
lrwxrwxrwx   1 nobody nogroup    4 Jun 30  2015 run -> /run
drwxr-xr-x+  5 nobody nogroup 4096 Oct  1  2016 spool
drwxrwxrwt+  2 nobody nogroup 4096 May  4  2015 tmp
drwxr-xr-x   7 nobody nogroup 4096 Apr 18  2019 vmail
drwxr-xr-x+  4 nobody nogroup 4096 Jul 13  2016 www

The ownership must be root.root instead.

Can you please advise how to fix this issue?

THX
 

fiona

Proxmox Staff Member
Staff member
Aug 1, 2019
2,452
491
88
Hi,
was the old container privileged and is the new one unprivileged?
 
  • Like
Reactions: cmonty14

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!