Cannot mount SMB drive

ajocius

New Member
Oct 1, 2023
16
3
3
I am trying to mount SMB2 drive to Proxmox, but failing so far. NAS is an old D-Link DNS323 with ALT-F running on it, where I enabled SMB2. I am able to access exposed folders in Windows and Android phone, but not able to mount in Proxmox. Getting error message

Error msg.png

Below is setup in ALT-F
DNS323.png

I found suggested solution in this forum to set up drive while leaving "Enable" option unchecked and yes, set up process went through, however Proxmox is not able to mount that drive and therefore I am not able to use it. I believe I have seen somewhere that SMB version should be 2.1, however I do not have that option. I did enabled NFS service as well and that one seem to have mounted, i can see it on the left menu, however I am not able to select it when for example installing new container. Any thoughts of what else can I try?
 
You could try to mount that SMB share manually via CLI. Either via autofs, fstab, systemd service or whatever. Then add a directory type storage to PVE pointing to the mountpoint of the SMB share. But make sure to enable "is_mountpoint" for that directory storage via "pvesm set" command so you are not accidentally filling up your root filesystem in case mounting fails.

Or you try to tell PVE to use SMB2 (and SMB1 isn't supported and you really should deactivate that on your NAS for security reasons): pvesm set YourStorageId --smbversion 2.0
 
Last edited:
I have disabled SMB1 in my NAS server.

I have tried to manually mount my shared drive, by adding following line into fstab file:
//192.168.1.106/dns323_1TB/Proxmox /media/DNS323_1TB cifs guest,uid=1000,iocharset=utf8 0 0

Prior that I did create "DNS323_1TB" subfolder within "media" folder.

I do get error "Invalid argument" when executing mount -a command, suspect the line I added to fstab file is causing this error. Is it the uid (followed instruction on Ubuntu wiki). By the way, I can access the path on NAS server from my windows machine using path "\\192.168.1.106\dns323_1TB\Proxmox". Please advice.

I am also not sure where should I enable "is_mountpoint" for that directory as adviced above.
 
Still struggling to manually mount shared drive. My last attempt did not give error immediatelly, but asks for password, even I did not set up password for this location. Any advice on the right syntax to use in fstab file?
//192.168.1.106/dns323_1TB/Proxmox /media/DNS323_1TB cifs uid=0,iocharset=utf8,noperm 0 0
 
I usually create a credentials file
Credentials file would contain user name and password, but I am not using those. I can access folder on NAS server as anonymous. When I am connecting to it from windows pc or Android mobile, I am not asked for any user name or password and that makes sense. I believe the problem must be somewhere else. Syntax perhaps or Samba version?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!