Cannot login as root


New Member
Jun 9, 2023
Hello Everyone,

I setup PMG in a cluster config with 2 nodes. I then added 2fa to the root user login on both nodes. I think this maybe was a mistake, because ever since then I've had problems.

First problem was:

- I cant login to the master node with password and tfa
- The secondary node never asked for the 2fa code.

I then disabled tfa on the master node by wiping the line from this file: /etc/pmg/tfa.json. I also subsequently tried moving this file to /tmp

The tfa seems to be turned off, but I still cannot login and get "Login failed. Please try again".

I have tried resetting roots password from cli using the passwd command and then even rebooting the server but still cannot get in.

I can access and login to the second node just fine during all of this. The second node does show the first node as the master.

Thanks for any help!
please share your journal and /var/log/pmgproxy/pmgproxy.log around the time where you fail to login as root.
This should help us in narrowing down the issue.
Ahh, I went to tail the log file for you and noticed less activity then I was expecting. I see in console:

POST https://mg1:8006/api2/extjs/access/ticket net::ERR_CERT_AUTHORITY_INVALID

I then ran: " pmgconfig apicert" to set a generic non signed certificate and then was able to login. Then I registered a new lets encyrpt one and seem to be in ok shape for right now.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!