Cannot log into LXC

79corvette

New Member
Jun 20, 2023
10
1
3
EDIT: like most of my problems, this seems to be UID/GID mapping related. I think I accidentally removed a line from /etc/subgid or /etc/subgid, because when I remove all of my custom mapping from /etc/pve/lxc/101.conf the container starts and permits me to login.

Mods feel free to delete this if you like, or leave up if the context might be helpful to someone in the future.



Leaving the context below, but I don't think it's relevant to my current issue anymore. Leaving it up in case anyone encounters an issue where they cannot

I started having a lot of problems today, hopefully this is enough context for someone to help guess what I should investigate next.

I have PVE 7.4.3 set up with 3x LXCs: Turnkey Fileserver, and 2x Ubuntu 22.10 for each of Jellyfin and Tailscale. I set up the tailscale LXC today, but everything else has been working well for days. After installing tailscale I played several videos from Jellyfin on my phone over its mobile data connection to verify the Tailscale install and subnet router funtionality were working and there were no issues.

After rebooting the pve node, I am now unable to log into the Jellyfin LXC shell. It returns a "login incorrect" error but I am certain I am typing the password correctly. Logging into the LXC from the pve shell returns the following, but appears to give me root in the LXC:
Code:
root@pve:~# pct enter 101
bash: /root/.bashrc: Permission denied
root@Jellyfin:/#

But attempting to change the password fails:
Code:
root@Jellyfin:/# passwd
New password:
Retype new password:
passwd: Authentication token manipulation error
passwd: password unchanged
root@Jellyfin:/#

Meanwhile the Jellyfin server itself is no longer working, but I dont think it makes sense to troubleshoot that until I resolve the issue(s) with the container. Sometimes it fails to display any of the media libraries, and rebooting the container occasionally causes some content to reappear. But even then the media always fails to play with the error "This client isn't compatible with the media and the server isn't sending a compatible media format", despite playing the same files fine yesterday.

I've tried all of my 6 backups from the last few days and all have the same problem where I cannot log into the LXC, and the media server does not function. Everything worked well when those backups were created and I am very confused how restoring them does not restore the functionality. I could delete the container and re-create it, but I would really prefer to understand what is causing this problem and learn how to correct it...

Any suggestions on how to troubleshoot further would be appreciated!
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!