Cannot create VPS in Proxmox due to kvm: -rtc base=now: invalid date format


Jul 3, 2019
While creating a new VPS on our Proxmox servers, I would expect to be able to set the RTC Start Date to 'now' as described in the manuals. However, every time I try, both with and without having ticked the 'Use local time for RTC' box, this fails.

When giving an actual date in this field, I CAN start the VPS without errors.

Could anyone tell me if -rtc base=now should have worked (now does not seem a 'valid format' ..?
And if it should have worked, then what could be causing this ?

kvm: -rtc base=now: invalid date format
valid formats: '2006-06-17T16:01:21' or '2006-06-17'

TASK ERROR: start failed: command '/usr/bin/kvm -id 100 -name -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/ -daemonize -smbios 'type=1,uuid=05bef2fb-78ce-4a99-8179-ada51c6a134f' -smp '1,sockets=1,cores=2,maxcpus=2' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc unix:/var/run/qemu-server/100.vnc,x509,password -cpu kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,enforce -m 512 -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 'vmgenid,guid=087aee43-010e-4dc4-851a-2f63d9d8ca12' -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -chardev 'socket,id=serial0,path=/var/run/qemu-server/100.serial0,server,nowait' -device 'isa-serial,chardev=serial0' -device 'VGA,id=vga,bus=pci.0,addr=0x2' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -device 'virtio-scsi-pci,id=scsihw0,bus=pci.0,addr=0x5' -drive 'file=/var/lib/vz/template/iso/CentOS-7-x86_64-Minimal-1810.iso,if=none,id=drive-scsi0,media=cdrom,aio=threads' -device 'scsi-cd,bus=scsihw0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0,id=scsi0,bootindex=200' -drive 'file=/var/lib/vz/images/100/vm-100-disk-0.raw,if=none,id=drive-virtio0,media=disk,cache=writethrough,format=raw,aio=threads,detect-zeroes=on' -device 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown' -device 'e1000,mac=02:00:00:54:03:1a,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300' -rtc 'base=now' -machine 'type=pc'' failed: exit code 1
what version of PVE are you running? (`pveversion -v`) It should be -rtc 'base=localtime' when you enable the checkbox, the 'now' is the parameter for the 'starttime' entry in the VM config (although it is set to now by default, so you should not need to set that).
For future reference:
Removing the 'startdate: now' from the /etc/pve/qemu/<vmid>.conf, and it then defaults to localtime in the kvm command. The input 'now' seems not to be a valid format (valid formats: '2006-06-17T16:01:21' or '2006-06-17') by kvm (anymore),


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!