Cannot Change Resolution In Windows 10 VM

mhayhurst

Well-Known Member
Jul 21, 2016
108
4
58
42
Hello everyone,

I have a Windows 10 VM (with the latest updates) running on Proxmox [pve-manager/6.1-5/9bf06119 (running kernel: 5.3.13-1-pve)]. I've gone into the OVMF EFI settings and adjusted the resolution to 1920x1080 but booting back into Windows 10 I'm still stuck at the 800x600 resolution. This will not work as some programs have options that are cut off because of the small resolution and the window cannot be resized. I've even installed the: spice-guest-tools which contains the QXL video driver but no success. I'm also unable to update the Display Adapter in the Device Manager Properties and it has defaulted to the Microsoft Basic Display Adapter. Would someone be able to tell me how to adjust the resolution in my Windows 10 VM?

1577034497012.png

1577034747291.png
 
Are you connecting to the VM via the console in Promox or RDP?

I think the console may be limiting the screen size, if you connect via RDP you should be able to access the full 1080p
 
I'm having a similar (likely the same) problem. I can adjust the resolution in OVMF settings, but this resolution will ONLY work when a reset is issued from this UEFI config interface or after a reboot of the VM. Any "cold" boot of the VM (non-restart/reset/reboot) results in 800x600 resolution. This is pretty annoying as it means that booting a VM always requires an immediate manual restart to get the console resolution up high enough to do anything except reminisce about 1996.

FYI: this is impacting ALL VMs configured with OVMF-UEFI.

pve-manager/6.1-5/9bf06119 (running kernel: 5.3.13-1-pve)
root@proxbox1:~# pveversion -a
Unknown option: a
USAGE: pveversion [--verbose]
root@proxbox1:~# man pveversion
root@proxbox1:~# pveversion -v
proxmox-ve: 6.1-2 (running kernel: 5.3.13-1-pve)
pve-manager: 6.1-5 (running version: 6.1-5/9bf06119)
pve-kernel-5.3: 6.1-1
pve-kernel-helper: 6.1-1
pve-kernel-5.3.13-1-pve: 5.3.13-1
pve-kernel-5.3.10-1-pve: 5.3.10-1
ceph: 14.2.5-pve1
ceph-fuse: 14.2.5-pve1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 1.2.8-1+pve4
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.1-3
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
openvswitch-switch: 2.10.0+2018.08.28+git.8ca7c82b7d+ds1-12+deb10u1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.1-2
pve-container: 3.0-15
pve-docs: 6.1-3
pve-edk2-firmware: 2.20191127-1
pve-firewall: 4.0-9
pve-firmware: 3.0-4
pve-ha-manager: 3.0-8
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-4
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2
 
Last edited:
Are you connecting to the VM via the console in Promox or RDP?

I think the console may be limiting the screen size, if you connect via RDP you should be able to access the full 1080p

Yes, you are correct. I get the resolution I want using RDP but I'm using NoMachine for my VM remote connections as it's convenient having everything accessible through "one pane of glass". I've seen where using "SeaBIOS" allows one to change the resolution but this would require a reinstall of Windows 10 and I have a few apps where the license cannot be moved. Since EFI is the norm now, it would seem everything that was possible with SeaBIOS should be possible with EFI...so is this a bug?
 
I'm having a similar (likely the same) problem. I can adjust the resolution in OVMF settings, but this resolution will ONLY work when a reset is issued from this UEFI config interface or after a reboot of the VM. Any "cold" boot of the VM (non-restart/reset/reboot) results in 800x600 resolution. This is pretty annoying as it means that booting a VM always requires an immediate manual restart to get the console resolution up high enough to do anything except reminisce about 1996.

Wow, same here! Your suggestion worked but if I reboot the Windows 10 VM it defaults back to the 800X600 resolution. And here's the worst part for me: in order to access the OVMF UEFI I must remove my external USB HDD I have set to passthrough from the Hardware section of the VM but I can not add it back unless I shutdown the VM which then results in the resolution defaulting back to 800X600!! This is beyond frustrating!!
 
Disabling the: "Turn on fast startup (recommended)" seems to retain the resolution but only if Windows is restarted from within the Windows VM. It will not work on a Reboot executed from Proxmox or with a Shutdown executed from Windows or Proxmox. If you do happen to shutdown Windows then simply restart it from within Windows and your resolution should be back to what you set it in the OVMF (UEFI) BIOS settings. Not a great solution but it works.

1588178353276.png
 
SOLUTION:

By default this can be perceived as a problem with Proxmox 7, however there is a solution:

Change your in the Hardware tab of your guest VM, change the Display type to VirtIO-GPU, then start up the guest VM again and if your VirtIO drivers are not installed, then install them and try seeing if your resolution improves or manually change it. I was able to get options all the way up to 2560x1600.

virtio.jpg

resolutions.jpg
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!