Can you run other virtualization in KVM Proxmox 6.0

Nested virtualization isn't relevant during installation so there must be something in the VM configuration it doesn't like or there is a bug. Have you tried other Linux distributions of that era with the same settings? Are you sure the iso you are using is good?
I downloaded the ISO right from Proxmox website. What Linux dist. with Virtualization capability do you recommend to test?
Almost any Linux will have "virtualization capability", as that is a kernel feature since 2.6 days. It can be un-configured when the kernel is built but I don't think any popular distros do that.

Proxmox 3.4 is apparently based on Debian Wheezy so that would be the one to try. You can get Wheezy ISO's at

Again, if the installation won't run you have something wrong that has nothing to do with Proxmox's KVM feature. I've installed Proxmox 5.4 in Virtualbox on a laptop which doesn't support nested virtualization at all. It installed fine and I could create containers but hw-accelerated VM's would give a "no kvm" error.
I downloaded the ISO right from Proxmox website. What Linux dist. with Virtualization capability do you recommend to test?
I have research searched the existing threads and could not figure out the resolution. Here is what I have so far in my non-working environment:
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Nov 15 15:12:53 2019 from
root@vpshost25:~# cat /sys/module/kvm_intel/parameters/nested
root@vpshost25:~# more /etc/modprobe.d/kvm-intel.conf
options kvm-intel nested=Y
root@vpshost25:~# modprobe -r kvm_intel
root@vpshost25:~# modprobe kvm_intel
root@vpshost25:~# cat /sys/module/kvm_intel/parameters/nested

This is following the existing document provided:

I also tried changing multiple parameters for the VM setup but no luck. Any other suggestions from other members are much appreciated.
I tried even a Centos 6.9 iso and I am getting the same result: boots but will not continue installation and after flashing reboots. I beleive this is related to the parameters (default) for creating the VM.
After reinstalling Proxmox 6.04 without any updates this was resolved.

root@vpshost25:~# pveversion --verbose
proxmox-ve: 6.0-2 (running kernel: 5.0.15-1-pve)
pve-manager: 6.0-4 (running version: 6.0-4/2a719255)
pve-kernel-5.0: 6.0-5
pve-kernel-helper: 6.0-5
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.10-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-2
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-5
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-61
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-5
pve-cluster: 6.0-4
pve-container: 3.0-3
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-5
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-3
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-5
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve1

I am suspecting the problem was a result of the update. For now I will not update but one of the issues will be not having the most recent version of LXC to run Centos 8.0.

Any suggestions???


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!