BSOD after Update


Oct 18, 2013
I updated my Proxmox system two days ago to the current pve-no-subscription packages. The update finished without any error messages and I restarted the Proxmox server. Right now the following software versions are installed on the server:
# pveversion -v
proxmox-ve-2.6.32: 3.2-126 (running kernel: 2.6.32-29-pve)
pve-manager: 3.2-4 (running version: 3.2-4/e24a91c1)
pve-kernel-2.6.32-20-pve: 2.6.32-100
pve-kernel-2.6.32-28-pve: 2.6.32-124
pve-kernel-2.6.32-25-pve: 2.6.32-113
pve-kernel-2.6.32-29-pve: 2.6.32-126
pve-kernel-2.6.32-26-pve: 2.6.32-114
pve-kernel-2.6.32-23-pve: 2.6.32-109
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.5-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.5-1
pve-cluster: 3.0-12
qemu-server: 3.1-16
pve-firmware: 1.1-3
libpve-common-perl: 3.0-18
libpve-access-control: 3.0-11
libpve-storage-perl: 3.0-19
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-6
vzctl: 4.0-1pve5
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 1.7-8
ksm-control-daemon: 1.1-1
glusterfs-client: 3.4.2-1

Everything went fine for one and a half day but then the KVM-VM with Windows Small Business Server 2008 had a blue screen with the error message IRQL_NOT_LESS_OR_EQUAL
I experienced the same problem some months ago. I solved this by selecting the CPU type "host" instead of "Default (kvm64)".
Does somebody have a hint how I can fix this problem or at least get a more detailed report about the reason of this BSOD. Because I can't find any hint for the reason of the BSOD in the logs of the Windows VM or in the logs of the Proxmox server.
Post your VM config.

> qm config VMID
The VM config is the following:
# qm config 100
boot: cdn
bootdisk: virtio0
cores: 2
cpu: host
description: Windows Small Business Server 2008 (64bit)
ide2: none,media=cdrom
memory: 16384
name: server1
net0: virtio=00:08:54:54:DF:D9,bridge=vmbr0
onboot: 1
ostype: w2k8
sockets: 1
startup: down=360
virtio0: data1:vm-100-disk-1,size=940G
virtio1: swap:vm-100-disk-1,size=32G

And yes I performed a kernel update of the host system. After installing all updates I first shut down all VMs and then restarted the host server.
do you run latest virtio drivers inside windows?

try to boot in safe mode.

and maybe try default CPU instead of "host".
I updated the virtio drivers inside windows and the machine is running solid so far. I hope that the update solved the problem.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!