Bridge interface configuration not working

ThomasB

Member
Nov 27, 2017
11
0
6
29
France
Hello,
After installing proxmox 5, on an HP DL360 gen9 server, I have a network interface configuration problem.

I realized the configuration of the two interfaces ETH0 and ETH1 in bridge on VMBR0 and VMBR1

So far no problem, it is trying to test the operation of both interfaces that it blocks.

If I type the ETH1 ifdown command, the interface does not fall is PING continuous, but if I ETH0 ifdown the two interfaces are shutdown

Nevertheless, after verification VMBR0 and VMBR1, are of course two different MAC addresses.

The bridge VMBR1 does not take into account ETH1, but earlier ETH0.

How to solve this problem ?


See screenshots.

Have a good day.
 

Attachments

  • network-interfaces_bug.png
    network-interfaces_bug.png
    10.7 KB · Views: 51
  • PING_ETH0-ETH1_bug.png
    PING_ETH0-ETH1_bug.png
    182.2 KB · Views: 42
  • MAC_Interface_bug.png
    MAC_Interface_bug.png
    14.2 KB · Views: 36
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,521
895
163
33
Vienna
you have mulitple gateways defined, this will not work since there can only be 1 default gateway (and since vmbr0s gateway comes first, this is the route which is configured)
also you have multiple ips in the same subnet, your host will react to both ip adresses regardless where the ping comes from

the real question is what do you want to achieve ?
 

ThomasB

Member
Nov 27, 2017
11
0
6
29
France
Hello dcsapak,

I want to connect two different LANs.

I also realized a test with a single gateway on VMBR0 by default, the problem is always the same on VMBR1 while it is the same LAN.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,521
895
163
33
Vienna
Ok, but I want to be able to assign a different interface for the wan output of a VM
what exactly do you mean by this?

maybe it helps if you describe your setup in more detail
 

ThomasB

Member
Nov 27, 2017
11
0
6
29
France
Hello,

Here is a diagram of the network, without firewall or other equipment to simplify the diagram.

Network.jpg
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,521
895
163
33
Vienna
sorry i still do not know what you are trying to achieve

do you want to use a different wan connection for a specific website ?
or do you want a second interface for a website on a different ip?
 

Oliver R

Member
Sep 11, 2017
79
6
13
Hi Thomas!

What do you want achive with your configuration? You want to use two different lans (subnet?) to reach your VMs with the eg. 192.168.100.0/24 subnet and the website (proxmox webinterface?) with eg. 192.168.200.0/24 right?
 

ThomasB

Member
Nov 27, 2017
11
0
6
29
France
Hello Oliver,

it is exactly the result that I wish to obtain, I tried at first to configure the interface without configuring vmbr0 and 1 with auto eth0 and auto eth1 ...

if i physically disconnect eth0 it also stops pinging eth1. the two flows actually pass on eth0 ... it's a real problem to separate streams.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!