[SOLVED] Bridge and interface does not start

Maksimus

Member
May 16, 2022
60
2
8
After unsuccessfully changing the network parameters, the bridge was assigned a vlan as the network adapter on which to work. After this, the server was lost from the network.
The network config was corrected and the server was rebooted, after which the bridge and the network interface on which this bridge is running stopped rising (this network faces the Internet), while the second network (local) and its bridge rose successfully.
When starting the network I get an error

root@Host803:~# ifup -a
vmbr1: the hash_elasticity option has been deprecated and is always 16
vmbr0: the hash_elasticity option has been deprecated and is always 16


Bash:
root@Host803:~# cat /etc/network/interfaces
# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
#
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

iface ens1f0 inet manual

iface usb0 inet manual

iface ens1f1 inet manual

auto vmbr0
iface vmbr0 inet static
        address 82.***.***.207/24
        gateway 82.***.***.1
        bridge-ports ens1f0
        bridge-stp off
        bridge-fd 0

auto vmbr1
iface vmbr1 inet static
        address 192.168.200.6/24
        bridge-ports ens1f1
        bridge-stp off
        bridge-fd 0

Bash:
root@Host806:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens1f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr0 state DOWN group default qlen 1000
    link/ether 08:f1:ea:db:02:a0 brd ff:ff:ff:ff:ff:ff
    altname enp92s0f0
3: ens1f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr1 state UP group default qlen 1000
    link/ether 08:f1:ea:db:02:a8 brd ff:ff:ff:ff:ff:ff
    altname enp92s0f1
4: usb0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether da:31:11:4e:63:53 brd ff:ff:ff:ff:ff:ff
5: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 08:f1:ea:db:02:a0 brd ff:ff:ff:ff:ff:ff
    inet 82.***.***.207/24 scope global vmbr0
       valid_lft forever preferred_lft forever
    inet6 fe80::af1:eaff:fedb:2a0/64 scope link
       valid_lft forever preferred_lft forever
6: vmbr1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 08:f1:ea:db:02:a8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.200.6/24 scope global vmbr1
       valid_lft forever preferred_lft forever
    inet6 fe80::af1:eaff:fedb:2a8/64 scope link
       valid_lft forever preferred_lft forever

Code:
proxmox-ve: 7.4-1 (running kernel: 5.15.107-2-pve)
pve-manager: 7.4-4 (running version: 7.4-4/4a8501a8)
pve-kernel-5.15: 7.4-3
pve-kernel-5.15.107-2-pve: 5.15.107-2
pve-kernel-5.15.102-1-pve: 5.15.102-1
ceph-fuse: 15.2.17-pve1
corosync: 3.1.7-pve1
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.1.0-1+pmx4
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.24-pve2
libproxmox-acme-perl: 1.4.4
libproxmox-backup-qemu0: 1.3.1-1
libproxmox-rs-perl: 0.2.1
libpve-access-control: 7.4-3
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.4-1
libpve-guest-common-perl: 4.2-4
libpve-http-server-perl: 4.2-3
libpve-rs-perl: 0.7.6
libpve-storage-perl: 7.4-3
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 5.0.2-2
lxcfs: 5.0.3-pve1
novnc-pve: 1.4.0-1
proxmox-backup-client: 2.4.2-1
proxmox-backup-file-restore: 2.4.2-1
proxmox-kernel-helper: 7.4-1
proxmox-mail-forward: 0.1.1-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.7.0
pve-cluster: 7.3-3
pve-container: 4.4-4
pve-docs: 7.4-2
pve-edk2-firmware: 3.20230228-2
pve-firewall: 4.3-2
pve-firmware: 3.6-5
pve-ha-manager: 3.6.1
pve-i18n: 2.12-1
pve-qemu-kvm: 7.2.0-8
pve-xtermjs: 4.16.0-2
qemu-server: 7.4-3
smartmontools: 7.2-pve3
spiceterm: 3.2-2
swtpm: 0.8.0~bpo11+3
vncterm: 1.7-1
zfsutils-linux: 2.1.11-pve1

Tell me what to do?
 
Last edited:
If you change the interfaces on which they operate on the bridges, the situation remains the same, only the host gains access to the Internet, but loses the local network.
According to the provider, they see the link on both the server and network equipment.
 
They pestered the provider and it turned out that they accidentally created a network loop inside the interface and the network equipment disabled the port.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!