Booting into proxmox PVE 8.0.2 on nvme using Clover

sumguy

New Member
Apr 5, 2022
13
3
3
I have an old system without nvme boot support. Dell R720XD. I've installed proxmox onto nvme disks - zfs mirror. Using clover - I cannot get either disk to boot. Clover lists internal disks but with no names. When I try to boot either one I just get a black screen and nothing ever happens. I did copy the nvme drivers over to the bios/uefi folders.

Anyone else having trouble like this? I tried an older version of Clover as well - same result. I will try a different type of install instead of zfs mirror, but after having a newish enterprise SSD boot disk crap out that was not mirrored...I've learned my lesson to always mirror.
 
Booting to ext4 works. Any idea why zfs will not? I am about to try xfs as well. But I would really like to have a zfs mirror for boot, so any help is greatly appreciated and probably will help a lot of people and not just me.
 
  • Like
Reactions: semanticbeeng
The boot loader has to understand enough of the filesystem to find the kernel and initrd. Does this Clover thing support ZFS?
It has a ZFS driver inside. But there must be something hanging it up. Could be an issue with Clover. rEFInd doesn't work either, though. Ext4 and btrfs work though. TrueNAS scale also works with zfs booting from Clover bootloader. So potentially could be something that could be adjusted with proxmox to fix it.
 
  • Like
Reactions: semanticbeeng

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!