Boot up problems Dell R720 & nvidia K2 GPU


New Member
Jul 22, 2023
Hello, I obtained a K2 to have a go at setting up a GPU on a W2k19 VM that i have set up running BlueIris (in an effort to take some load off the CPU) and to enable OpenGL on another VM running W2k19 Quake 3 server. omg what a mission its turning into :) . The Proxmox GUI is fantastic and very intuitive.

Not sure the K2 card is actually working so i have a couple of question hoping someone can help me pce this together.

After installing the card in the R720 (yes it has dual 1kw psu and the correct cable). Worth noting that the K2 can be configured with both 8 and 6 pin GPU connected according to the Nvidia Manual. However on the Dell R720 the card is only picked up by the system when the 8pin is connected on its own. (Doing some research it looks like that is a known issue on IBM servers, sounds like Dell 720 are also impacted)

Anycase... Here is the issue. I do not see the Card detailed in any of the BIOS or system inventories held on the server itself, once I exit setup or lifecycle when it gets to pre-boot I see the following error and system halts. Is this stage of the system boot looking at the host OS i.e Proxmox for a Nvida driver or a setting that sets up the K2 so that it can be seen in Proxmox? (I suspect pre-boot is unrelated to Proxmox and is actually confirming the K2 is dead). Can anyone help confirm my understanding or correct it? k2 preboot.jpg So no luck in getting the PCI passthought to Proxmox..... interestingly I have an Alienware A51 (great machine and still running stong!) I managed to install the K2 along side an GTX and it was picked up by Window 10 as a second GPU, I was able to install the drivers and Window popped up with Grid K2 GPU. Fantastic... However required a reboot and at that stage it all went down hill... ended up blue-screening and I had to remove the card to get the system to recover. I suspect the K2 is not compatible with Win10?!?!

Anyone got any suggestion on what else to test :)... I didnt pay a lot for the card, but i hate giving up..
Keen share progress in an effort to help anyone that faces the same issue.

I still have the error, however the Dell R720 is now showing the K2 in the inventory :)

I found out that I had no OS drivers installed (se below) the server inventory has many devices and i had only focused on BIOS firmware when checking for the latest version.


So downloaded from Dell the following software and I was able to install this on the fly via the iDRAC (it seems the Update function on the iDRAC will upload and process .EXE)

Driver package details


(The release note makes ref to

September 2015 Block Windows and Linux OS Drivers for the Deployment of Server OS via Lifecycle controller
Supported OS list :
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2008 x86 with SP2
Microsoft Windows Server 2008 x64 with SP2
Microsoft Windows Server 2008 R2 SP1
Red Hat Enterprise Linux 6.7 x86_64
Red Hat Enterprise Linux 7.1 x86_64
SUSE Linux Enterprise Server 11 SP4 x86_64
SUSE Linux Enterprise Server 12 x86_64
VMware ESXi
Citrix Xen Server

Interesting note

NOTE:If you select VMware ESXi,Citrix XenServer, or select the Any Other Operating System option, make sure that you prepare the drivers required for installing these operating systems because the drivers not available.

K2 register in system inventory :)


This confirmed imo, the card is OK and now being picked up by the R720.

Interesting if you remove the 8 pin power and leave the card in the Dell R720 (i.e running off the PCI bus power) I get the following error :) - so i think if you have a Power Cable issue you are likely to see the following boot up error. (I have seen many screen shots from people having K2 issues and seeing the following error...


back to the issue

During the Dell R720 boot SEQ. I now see the following...

1st Welcome to GRUB


and then... I get the same type of error.


So my conclusion... I see the card registered on the Server Inventory (out side of any OS).

During boot-up its now clear Proxmox / Installed OS is in control. As i get a screen welcome to Grub and then after a short period the system crashes.

Can anyone suggest a way for me to install or check the drivers in Proxmox? I hope someone can...

In the meantime I will investigate who to install the Linux OS deployment for R720 which is named :-


I suspect I need to enter Dell Life-cycle manager to install that BIN file, as the iDRAC will not upload directly and looking at that note from the release i suspect i need the BIN file installed as there are some known compatibility issues


  • Slide1.JPG
    121 KB · Views: 1
  • Slide4.JPG
    74.2 KB · Views: 3
Last edited:
update... I was unable to get the K2 to work with Proxmox 8, in the end i flatten and install Exis 6.5 and it worked 1st time no issues... for info I was able to upgrade Exis to 6.7 (Dell provided version for R720) and it worked.

Any ideas why this card will not work with Proxmox... sounds like a IRQ issue, however applied all the exclusion and added the bypassed IRQ commands.. no joy :(


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!