boot failed: not a bootable disk

Nov 20, 2017
23
0
1
37
Canada
somebody please help me, I can use restore backup in this vm

I created a VM CentOS 7, and Back-up using other storage NFS.

I can restore VM, but when i try to start ( using new ID vm) , the vm have problem with boot;

boot failed: not a bootable disk
iPXE -- Open Source Network Boot Firmware -- http://ipxe.org
Features: HTTP iSCSI DNS TFTP AoE FCoE TFTP COMBOOT ELF PXE PXEXT

Press Ctrl-B for the iPXE command line...
net0: A2:B0:75:C0:DA:CE using virtio-net on 0000:00:12.0 (open)
[Link:up, TX:0 TXE:0 RX:0 RXE:0]
Configuring ( net0 A2:B0:75:C0:DA:CE)........... No configuration Methods

This is config of y vm.


agent: 1
bootdisk: sata0
cores: 4
memory: 8200
name: my-server
net0: virtio=A2:B0:75:C0:DA:CE,bridge=vmbr208
numa: 0
onboot: 1
ostype: l26
sata0: Storage-RBD:vm-115-disk-1,cache=writethrough,size=100G
scsihw: virtio-scsi-pci
smbios1: uuid=01c7cde1-d3cf-4c37-99de-7358853ab9c9
sockets: 1



*******show configuration backup ****************

agent: 1
bootdisk: sata0
cores: 4
memory: 8200
name: my-server
net0: virtio=CE:64:8B:52:E9:63,bridge=vmbr208
numa: 0
onboot: 1
ostype: l26
sata0: ceph-vm:vm-105-disk-1,size=100G
scsihw: virtio-scsi-pci
smbios1: uuid=01c7cde1-d3cf-4c37-99de-7358853ab9c9
sockets: 1
#qmdump#map:sata0:drive-sata0:ceph-vm::


pveversion -v
proxmox-ve: 5.1-36 (running kernel: 4.13.13-5-pve)
pve-manager: 5.1-42 (running version: 5.1-42/724a6cb3)
pve-kernel-4.13.13-4-pve: 4.13.13-35
pve-kernel-4.13.13-2-pve: 4.13.13-33
pve-kernel-4.10.17-2-pve: 4.10.17-20
pve-kernel-4.13.13-5-pve: 4.13.13-36
libpve-http-server-perl: 2.0-8
lvm2: 2.02.168-pve6
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-19
qemu-server: 5.0-19
pve-firmware: 2.0-3
libpve-common-perl: 5.0-25
libpve-guest-common-perl: 2.0-14
libpve-access-control: 5.0-7
libpve-storage-perl: 5.0-17
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-3
pve-docs: 5.1-16
pve-qemu-kvm: 2.9.1-6
pve-container: 2.0-18
pve-firewall: 3.0-5
pve-ha-manager: 2.0-4
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.1.1-2
lxcfs: 2.0.8-1
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.7.3-pve1~bpo9
ceph: 12.2.2-pve1
 

Richard

Proxmox Staff Member
Staff member
Mar 6, 2015
719
25
28
Austria
I created a VM CentOS 7, and Back-up using other storage NFS.

I can restore VM, but when i try to start ( using new ID vm) , the vm have problem with boot;
AFAIU you restored the VM (into another ID) and the newly created VM does not boot.


* Does the original VM still boot correctly? If no: the VM was already corrupt before backing it up; if yes:

* boot the new VM with a live media and investigate the restored disk, mainly the boot sector and partition, compare it's content with the well working VM
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!