Backup Restore Failed

Ronny

Member
Sep 12, 2017
39
0
6
35
Hello,

on one of our proxmox single hosts we had an vm-crash.
so we tryed to restore the vm from backup - but every time we run the restore we get this error:

we have 3 backups from this vm - all get the same error and can't restored :(
backups from other vm's are fine and could restored.


we have copy'd to an other proxmox host and run the restore again - the same :(

here are the restore-log:

restore vma archive: lzop -d -c /var/lib/vz/dump/vzdump-qemu-202-2019_03_31-00_02_39.vma.lzo | vma extract -v -r /var/tmp/vzdumptmp5840.fifo - /var/tmp/vzdumptmp5840
CFG: size: 540 name: qemu-server.conf
DEV: dev_id=1 size: 42949673472 devname: drive-scsi0
DEV: dev_id=2 size: 42949673472 devname: drive-scsi1
DEV: dev_id=3 size: 2147483648000 devname: drive-scsi2
CTIME: Sun Mar 31 00:02:40 2019
Formatting '/var/lib/vz/images/205/vm-205-disk-0.qcow2', fmt=qcow2 size=42949673984 cluster_size=65536 preallocation=metadata lazy_refcounts=off refcount_bits=16
new volume ID is 'local:205/vm-205-disk-0.qcow2'
map 'drive-scsi0' to '/var/lib/vz/images/205/vm-205-disk-0.qcow2' (write zeros = 0)
Formatting '/var/lib/vz/images/205/vm-205-disk-1.qcow2', fmt=qcow2 size=42949673984 cluster_size=65536 preallocation=metadata lazy_refcounts=off refcount_bits=16
new volume ID is 'local:205/vm-205-disk-1.qcow2'
map 'drive-scsi1' to '/var/lib/vz/images/205/vm-205-disk-1.qcow2' (write zeros = 0)
Formatting '/var/lib/vz/images/205/vm-205-disk-2.qcow2', fmt=qcow2 size=2147483648000 cluster_size=65536 preallocation=metadata lazy_refcounts=off refcount_bits=16
new volume ID is 'local:205/vm-205-disk-2.qcow2'
map 'drive-scsi2' to '/var/lib/vz/images/205/vm-205-disk-2.qcow2' (write zeros = 0)
progress 1% (read 22333882368 bytes, duration 266 sec)
progress 2% (read 44667699200 bytes, duration 553 sec)
progress 3% (read 67001516032 bytes, duration 887 sec)

** (process:5843): ERROR **: restore failed - got wrong block address - write beyond end
/bin/bash: line 1: 5842 Broken pipe lzop -d -c /var/lib/vz/dump/vzdump-qemu-202-2019_03_31-00_02_39.vma.lzo
5843 Trace/breakpoint trap | vma extract -v -r /var/tmp/vzdumptmp5840.fifo - /var/tmp/vzdumptmp5840
temporary volume 'local:205/vm-205-disk-1.qcow2' sucessfuly removed
temporary volume 'local:205/vm-205-disk-2.qcow2' sucessfuly removed
temporary volume 'local:205/vm-205-disk-0.qcow2' sucessfuly removed
no lock found trying to remove 'create' lock
TASK ERROR: command 'set -o pipefail && lzop -d -c /var/lib/vz/dump/vzdump-qemu-202-2019_03_31-00_02_39.vma.lzo | vma extract -v -r /var/tmp/vzdumptmp5840.fifo - /var/tmp/vzdumptmp5840' failed: exit code 133


who can help me?
any idea?

thanks a lot
 

Vurdalak_89

New Member
Mar 21, 2019
5
0
1
30
Tried to unpack the archive manually?

1) lzop -d /dirbackup/vzdump-qemu-xxxx.vma.lzo
2) vma extract vzdump-qemu-xxxx.vma ./extract

WMA utility included in proxmox
Then try inserting the image file into the virtual machine.
 

Ronny

Member
Sep 12, 2017
39
0
6
35
sorry, i'm not finished.

the first step was successfull, now it runs the second...
i will keep you up-to-date :)
 

Ronny

Member
Sep 12, 2017
39
0
6
35
the second step failed with the same error - look at my screenshot.
there are 3 disks inside, the first and second restored fine but the last big one is broken.

upload_2019-4-9_9-59-22.png
 

Vurdalak_89

New Member
Mar 21, 2019
5
0
1
30
There are suspicions of problems with RAM or HDD. But you wrote that they gave the car to another host.

I ran out of ideas. ((

Found similar problems that occurred with other users. I did not know whether you were looking through their messages or not.

https://forum.proxmox.com/threads/backup-restore-failing.13123/
https://forum.proxmox.com/threads/cannot-restore-vm-backup-image-at-5-0beta1-5-0-5-error-restore-failed-wrong-vma-extent.33820/#post-166109

P.S

Is it possible to create a backup VM only with a problem hard disk, without compression? And try to extract it separately.

I correctly understood the HDD, which you can not recover, has a volume of 2 TB (2000 GB).
How is the backup performed? External HDD or FreeNas?
 

Ronny

Member
Sep 12, 2017
39
0
6
35
the hint about probs of ram and/or hdd i've also read in proxmox forum.
and yes - i tryed on an other host and there is the same error, so i've just saved the time with memory testing.

correct, the 3rd hdd is 2TB big and cannot recover. the backup drive is for proxmox an local directory, but an remote smb-share to an "hetzner-storage-box"... what the problem could be...

meanwhile we've recovered the vm and the data from the scratch.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!