Backup error

thomasddiego

Member
Dec 17, 2021
21
2
8
Good afternoon,

I have 9 Proxmox Virtual Environment 7.1-7 nodes and 1 Proxmox Backup Server 2.1-1 node.

A VM is showing the error below on Proxmox Backup Server:

2023-09-18T16:07:16-03:00: starting new backup on datastore 'BackupUnit': "vm/169/2023-09-18T19:07:13Z"
2023-09-18T16:07:16-03:00: GET /previous: 400 Bad Request: no valid previous backup
2023-09-18T16:07:16-03:00: created new fixed index 1 ("vm/169/2023-09-18T19:07:13Z/drive-ide0.img.fidx")
2023-09-18T16:07:16-03:00: add blob "/mnt/datastore/BackupUnit/vm/169/2023-09-18T19:07:13Z/qemu-server.conf.blob" (330 bytes, comp: 330)
2023-09-18T16:07:28-03:00: backup ended and finish failed: backup ended but finished flag is not set.
2023-09-18T16:07:28-03:00: removing unfinished backup
2023-09-18T16:07:28-03:00: TASK ERROR: backup ended but finished flag is not set.

When I run Proxmox VE and run the backup manually, this is the error:

INFO: starting new backup job: vzdump 169 --storage Bkp-Server --remove 0 --node italia --mode snapshot
INFO: Starting Backup of VM 169 (qemu)
INFO: Backup started at 2023-09-18 16:59:27
INFO: status = stopped
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: VM Name: finland
INFO: include disk 'ide0' 'DELL-NFS-uruguay:169/vm-169-disk-1.raw' 80G
INFO: creating Proxmox Backup Server archive 'vm/169/2023-09-18T19:59:27Z'
INFO: starting kvm to execute backup task
INFO: started backup task '15aad722-59b9-4569-a7ae-b68b237b38b9'
ERROR: VM 169 qmp command 'query-pbs-bitmap-info' failed - got timeout
INFO: aborting backup job
INFO: stopping kvm after backup task
ERROR: Backup of VM 169 failed - VM 169 qmp command 'query-pbs-bitmap-info' failed - got timeout
INFO: Failed at 2023-09-18 16:59:42
INFO: Backup job finished with errors
TASK ERROR: job errors


I have already tried to follow the procedure to change the flag, but when executing the pbs command in the Proxmox Backup Server Shell the command not found message appears.

Remembering that I have more than 40 VMs making backups and only this problem.

Any personal suggestions?
 
Last edited:
Hi,
you are running outdated versions.

Please upgrade both, your Proxmox VE and Proxmox Backup Server to the latest versions.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!