Audio from Debian VM to SPICE or TeamViewer client

Nixellion

New Member
Mar 6, 2019
14
0
1
33
Hello! I'm trying to get audio from Debian9 VM (MATE desktop if it matters) to windows spice client.


VM is Machine Q35 and ` args: -device intel-hda,id=sound5,bus=pci.0,addr=0x18 -device hda-micro,id=sound5-codec0,bus=sound5.0,cad=0 -device hda-duplex,id=sound5-codec1,bus=sound5.0,cad=1 ` added to config. Debian guest can see audio device as High Definition Audio Controller (QEMU virtual machine). I also tried with AC97 config line as docs suggest.

I tried with SPICE and TeamViewer and can't get audio to work. In TeamViewer "Computer sound" checkbox is just greyed out.

So how can I get audio working from my guest VM to the client? Any advice? Did I miss something?

Thanks for your time and attention!
 
UPDATE

Connected a USB sound card to the host, passed through to the VM and I can confirm that sound from VM is working if I connect headphones to the soundcard.

Looks like TeamViewer may just not support audio from Linux guests.

Is it the same with SPICE? Or is there any way to get audio from Guest VM to Client?
 
Here's what I get in client logs regarding audio:

(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.387: ../../src/channel-playback.c:346 playback-5:0: playback_handle_mode: time 66944572 mode 3 data 0000000006EB1E56 size 0
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.388: ../../src/spice-gstaudio.c:370 playback volume changed to 65535 (100.00)

(remote-viewer.exe:14404): GLib-GObject-CRITICAL **: 01:18:06.388: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(remote-viewer.exe:14404): GLib-GObject-CRITICAL **: 01:18:06.388: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.389: ../../src/spice-gstaudio.c:396 playback mute changed to 0

(remote-viewer.exe:14404): GLib-GObject-CRITICAL **: 01:18:06.389: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.394: ../../src/spice-channel.c:1296 display-2:0: channel up, state 3
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.394: ../../src/channel-display.c:1040 display-2:0: spice_display_channel_up: cache_size 83886080, glz_window_size 67108864 (bytes)
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.396: ../../src/spice-channel.c:2693 inputs-3:0: Open coroutine starting 00000000051572A0
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.397: ../../src/spice-channel.c:2534 inputs-3:0: Started background coroutine 0000000005157148
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.398: ../../src/spice-session.c:2202 Missing port value, not attempting unencrypted connection.
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.398: ../../src/spice-channel.c:2560 inputs-3:0: trying with TLS port
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.399: ../../src/spice-session.c:2214 inputs-3:0: Using TLS, port 61000
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.399: ../../src/spice-channel.c:2693 cursor-4:0: Open coroutine starting 0000000005154120
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.399: ../../src/spice-channel.c:2534 cursor-4:0: Started background coroutine 0000000005153FC8
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.400: ../../src/spice-session.c:2202 Missing port value, not attempting unencrypted connection.
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.400: ../../src/spice-channel.c:2560 cursor-4:0: trying with TLS port
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.400: ../../src/spice-session.c:2214 cursor-4:0: Using TLS, port 61000
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.401: ../../src/spice-session.c:2162 (with proxy http://192.168.1.11:3128)
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.401: ../../src/spice-session.c:2162 (with proxy http://192.168.1.11:3128)
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.401: ../../src/spice-channel.c:1296 record-6:0: channel up, state 3
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.401: ../../src/spice-session.c:2086 proxy lookup ready
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.402: ../../src/spice-session.c:2069 inputs-3:0: connecting 0000000009A1FE10...
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.402: ../../src/spice-session.c:2086 proxy lookup ready
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.402: ../../src/spice-session.c:2069 cursor-4:0: connecting 0000000009C1FE10...
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.403: ../../src/spice-gstaudio.c:429 record volume changed to 0 (0.00)

(remote-viewer.exe:14404): GSpice-WARNING **: 01:18:06.403: gst lacks volume capabilities on src

(remote-viewer.exe:14404): GLib-GObject-CRITICAL **: 01:18:06.404: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.404: ../../src/spice-gstaudio.c:455 record mute changed to 0

(remote-viewer.exe:14404): GSpice-WARNING **: 01:18:06.406: gst lacks mute capabilities on src: 0

(remote-viewer.exe:14404): GLib-GObject-CRITICAL **: 01:18:06.407: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.407: ../../src/spice-session.c:2053 inputs-3:0: connect ready
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.408: ../../src/spice-channel.c:2456 inputs-3:0: Load CA, file: (NULL), data: 0000000004D5E780
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.408: ../../src/spice-session.c:2053 cursor-4:0: connect ready
(remote-viewer.exe:14404): GSpice-DEBUG: 01:18:06.408: ../../src/spice-channel.c:2456 cursor-4:0: Load CA, file: (NULL), data: 0000000004D5E780
(remote-viewer.exe:14404): Spice-DEBUG: 01:18:06.411: ../../../spice-common/common/ssl_verify.c:407:verify_subject: subjects match
(remote-viewer.exe:14404): Spice-DEBUG: 01:18:06.412: ../../../spice-common/common/ssl_verify.c:407:verify_subject: subjects match
 
Is it the same with SPICE?

The Windows SPICE client is unfortunately not that good. I've running SPICE on Debian with audio and file sharing without a problem, but with the Linux SPICE client, the windows client does not offer all features. I have, however, running a SPICE client on Linux in a VirtualBox VM that has sound then. I know a lot of virtualisation to get it working, but it works.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!