[SOLVED] apt upgrade -> unerfüllte abhängigkeiten

astrakid

Active Member
Jun 13, 2013
72
1
28
hi,
hab seit ein paar tagen das problem, das ich kein upgrade mehr machen kann:


Code:
user@pveserver:~# sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 pve-firmware : Kollidiert mit: firmware-linux-free aber 3.4 soll installiert werden
E: Beschädigte Pakete


kann ich bedenkenlos ein full-upgrade durchführen?
Code:
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook)     touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook)     - your APT repository settings
W: (pve-apt-hook)     - that you are using 'apt full-upgrade' to upgrade your system
E: Unterprozess /usr/share/proxmox-ve/pve-apt-hook hat Fehlercode zurückgegeben (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

hab ein bisschen sorge, dass ich danach ohne pve dastehe...

gruß,
andre
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,975
820
163
33
Vienna
ist vielleicht noch ein stock-debian kernel installiert? wenn ja bitte den entfernen
 

astrakid

Active Member
Jun 13, 2013
72
1
28
Code:
user@pveserver:~# dpkg --list | grep linux-image
ii  linux-image-3.16.0-4-amd64                                  3.16.39-1+deb8u2                           amd64        Linux 3.16 for 64-bit PCs
rc  linux-image-3.2.0-4-amd64                                   3.2.78-1                                   amd64        Linux 3.2 for 64-bit PCs
rc  linux-image-4.9.0-2-amd64                                   4.9.18-1                                   amd64        Linux 4.9 for 64-bit PCs (signed)
rc  linux-image-4.9.0-3-amd64                                   4.9.30-2+deb9u5                            amd64        Linux 4.9 for 64-bit PCs
rc  linux-image-4.9.0-4-amd64                                   4.9.65-3+deb9u1                            amd64        Linux 4.9 for 64-bit PCs
rc  linux-image-4.9.0-5-amd64                                   4.9.65-3+deb9u2                            amd64        Linux 4.9 for 64-bit PCs
rc  linux-image-4.9.0-6-amd64                                   4.9.88-1+deb9u1                            amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-7-amd64                                   4.9.110-3+deb9u2                           amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-8-amd64                                   4.9.144-3                                  amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64                                           4.9+80+deb9u6                              amd64        Linux for 64-bit PCs (meta-package)
user@pveserver:~# uname -a
Linux server 4.15.18-13-pve #1 SMP PVE 4.15.18-37 (Sat, 13 Apr 2019 21:09:15 +0200) x86_64 GNU/Linux

dann müsste ich ja alle weghauen, oder?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,975
820
163
33
Vienna
dann müsste ich ja alle weghauen, oder?
ja alle die im status 'ii' sind, sind auch installiert, die bitte mittels 'apt remove' entfernen, dann das upgrade nochmal starten, dann sollte es klappen
 

astrakid

Active Member
Jun 13, 2013
72
1
28
danke, hat geklappt. hab aber nur die ersten deinstalliert, das hat gereicht.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!