[SOLVED] application not enabled on pool '.mgr'

BitterLemon

New Member
Sep 2, 2023
2
0
1
Hello everyone.

I recently set up a 3 node cluster with Ceph storage. Since the cluster was already running with local storage, I tried a 'rolling' deployment of Ceph. Meaning I reinstalled Proxmox one node at a time, then re-add that node to the cluster, install Ceph, then gradually moved VM disks over.
This worked great and my cluster is now running all my VMs with Ceph.

However, it seems Ceph has created an .mgr pool that I don't know about. It is complaining that there is no application enabled on the pool

Code:
application not enabled on pool '.mgr'
use 'ceph osd pool application enable <pool-name> <app-name>', where <app-name> is 'cephfs', 'rbd', 'rgw', or freeform for custom applications.

What is this .mgr pool? Do I need to assign an application? Which one? Should I delete it? So many questions .

I have attached two screenshots. Hope someone can shed some light on this.

Thanks!
 

Attachments

  • CleanShot 2023-09-02 at 10.45.56@2x.png
    CleanShot 2023-09-02 at 10.45.56@2x.png
    53.2 KB · Views: 9
  • CleanShot 2023-09-02 at 10.45.49@2x.png
    CleanShot 2023-09-02 at 10.45.49@2x.png
    64 KB · Views: 9
Hello,

Pools have to have an associated application before they can be used [1], in the case of the `.mgr` it should associated to the `mgr` application by default.

The `.mgr` pool is an internal Ceph pool, previously called `device_health_metrics` [2].

Did you upgrade from Ceph 16 to 17? Whats the output of `ceph osd pool ls detail`? What pool do you use for storing your data?

[1] https://docs.ceph.com/en/latest/rados/operations/pools/#associating-a-pool-with-an-application
[2] https://docs.ceph.com/en/quincy/mgr/index.html
 
Last edited:
Hello,

Here is the output of ceph osd pool ls detail
Code:
root@pve1:~# ceph osd pool ls detail
pool 8 '.mgr' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 1 pgp_num 1 autoscale_mode on last_change 1441 flags hashpspool stripe_width 0 pg_num_max 32 pg_num_min 1
pool 11 'vmdisks' replicated size 3 min_size 2 crush_rule 0 object_hash rjenkins pg_num 512 pgp_num 512 autoscale_mode on last_change 3349 lfor 0/0/2712 flags hashpspool,selfmanaged_snaps stripe_width 0 application rbd

I store the disks of my VMs on 'vmdisks'.

I did not upgrade from Ceph 16 to 17, this is a clean installation of Proxmox 8 and Ceph 17.2.6.

Enabling the mgr application on the .mgr was easy enough. So I guess we can close this thread :)

Code:
root@pve1:~# ceph osd pool application enable .mgr mgr
enabled application 'mgr' on pool '.mgr'

Thank you Maximiliano!
 

Attachments

  • Screenshot from 2023-09-05 10-09-01.png
    Screenshot from 2023-09-05 10-09-01.png
    17.1 KB · Views: 5

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!