AMD GPU Drivers

flux687

New Member
Apr 28, 2021
6
0
1
31
G'day,

Has anyone been successful at installing AMDGPU drivers on proxmox? specifically for the RX570?

I have not been successful in my endeavours so far. The GPU will be accessed via containers to provide transcoding.

vainfo does see that the GPU, however it reports the incorrect one, and I assume the wrong mesa driver is loaded.

vainfo:
Code:
error: can't connect to X server!
libva info: VA-API version 1.10.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_10
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.10 (libva 2.10.0)
vainfo: Driver version: Mesa Gallium driver 21.0.1 for AMD Radeon (TM) RX 470 Graphics (POLARIS10, DRM 3.35.0, 5.4.106-1-pve, LLVM 11.0.1)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc

The container can see the GPU, however no transcoding is conducted.

At this point I'm considering purchasing an Nvidia card, they seem more widely accepted.

Any help on the issue will be greatly appreciated.
 

Ingo S

Well-Known Member
Oct 16, 2016
230
26
48
38
Hello flux

In general the 570 should work. I am no expert but i have been digging a little bit into some information about virtualizing graphics adapters and i would not recommend switching to an nvidia card. I am not sure but it might be the case that you have to get a special license for video encoding from nvidia if you need to encode more than (i think it was...) 2 video streams simultaneously. These licenses are very expensive.

The 570 is a little bit old and i have heard that linux and virtualization support has very much increased on the AMD side, since the release of the 5800 series. It could be worth a try, but I'm not sure if containers use GPU virtualization. It also just might be a dumb and simple issue with the driver itself...
 

flux687

New Member
Apr 28, 2021
6
0
1
31
Hello flux

In general the 570 should work. I am no expert but i have been digging a little bit into some information about virtualizing graphics adapters and i would not recommend switching to an nvidia card. I am not sure but it might be the case that you have to get a special license for video encoding from nvidia if you need to encode more than (i think it was...) 2 video streams simultaneously. These licenses are very expensive.

The 570 is a little bit old and i have heard that linux and virtualization support has very much increased on the AMD side, since the release of the 5800 series. It could be worth a try, but I'm not sure if containers use GPU virtualization. It also just might be a dumb and simple issue with the driver itself...
Have you installed the drivers for amd?
 

flux687

New Member
Apr 28, 2021
6
0
1
31
I have just tried installing everything manually, however it fails. It's dependent on libc6 being greater than 2.28.

Is libc6 2.29 being implemented any time soon?
 

flux687

New Member
Apr 28, 2021
6
0
1
31
No, we do not have this type of scenario, we don't use graphics/video rendering on our Servers.
If the latest driver requires libc6 > 2.28, maybe an older driver can be used with libc6 = 2.28
Upon further investigation, it seems as though it is asking to install the 32 as well as 64 bit. From my understanding, proxmox does not support mulitarch?

Code:
amdgpu : Depends: amdgpu-lib (= 21.10-1247438) but it is not going to be installed
 amdgpu-lib32 : Depends: amdgpu-lib (= 21.10-1247438) but it is not going to be installed or
                         amdgpu-lib-hwe (= 21.10-1247438) but it is not installable
                Depends: libdrm2-amdgpu:i386 (= 1:2.4.100-1247438)
                Depends: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.100-1247438)
                Depends: libllvm11.0-amdgpu:i386 (= 1:11.0-1247438)
                Depends: libxatracker2-amdgpu:i386 (= 1:20.3.4-1247438)
                Depends: libgbm1-amdgpu:i386 (= 1:20.3.4-1247438)
                Depends: libegl1-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libegl1-amdgpu-mesa-drivers:i386 (= 1:20.3.4-1247438)
                Depends: libgles1-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libgles2-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libglapi-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libgl1-amdgpu-mesa-glx:i386 (= 1:20.3.4-1247438)
                Depends: libgl1-amdgpu-mesa-dri:i386 (= 1:20.3.4-1247438)
                Depends: mesa-amdgpu-va-drivers:i386 (= 1:20.3.4-1247438)
                Depends: mesa-amdgpu-vdpau-drivers:i386 (= 1:20.3.4-1247438)
 amdgpu-pro : Depends: libgl1-amdgpu-pro-ext (= 21.10-1247438) but it is not going to be installed
              Depends: libgl1-amdgpu-pro-dri (= 21.10-1247438) but it is not going to be installed
 amdgpu-pro-lib32 : Depends: libgl1-amdgpu-pro-glx:i386 (= 21.10-1247438)
                    Depends: libegl1-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libgles2-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libglapi1-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libgl1-amdgpu-pro-dri:i386 (= 21.10-1247438)
 vulkan-amdgpu-pro : Depends: libgcc-s1 (>= 3.3.1) but it is not installable
 vulkan-amdgpu-pro:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable
                          Depends: libgcc-s1:i386 (>= 3.3.1) but it is not installable
                          Depends: libstdc++6:i386 (>= 4.9) but it is not installable
                          Depends: libwayland-client0:i386 but it is not installable
 

flux687

New Member
Apr 28, 2021
6
0
1
31
Upon further investigation, it seems as though it is asking to install the 32 as well as 64 bit. From my understanding, proxmox does not support mulitarch?

Code:
amdgpu : Depends: amdgpu-lib (= 21.10-1247438) but it is not going to be installed
amdgpu-lib32 : Depends: amdgpu-lib (= 21.10-1247438) but it is not going to be installed or
                         amdgpu-lib-hwe (= 21.10-1247438) but it is not installable
                Depends: libdrm2-amdgpu:i386 (= 1:2.4.100-1247438)
                Depends: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.100-1247438)
                Depends: libllvm11.0-amdgpu:i386 (= 1:11.0-1247438)
                Depends: libxatracker2-amdgpu:i386 (= 1:20.3.4-1247438)
                Depends: libgbm1-amdgpu:i386 (= 1:20.3.4-1247438)
                Depends: libegl1-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libegl1-amdgpu-mesa-drivers:i386 (= 1:20.3.4-1247438)
                Depends: libgles1-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libgles2-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libglapi-amdgpu-mesa:i386 (= 1:20.3.4-1247438)
                Depends: libgl1-amdgpu-mesa-glx:i386 (= 1:20.3.4-1247438)
                Depends: libgl1-amdgpu-mesa-dri:i386 (= 1:20.3.4-1247438)
                Depends: mesa-amdgpu-va-drivers:i386 (= 1:20.3.4-1247438)
                Depends: mesa-amdgpu-vdpau-drivers:i386 (= 1:20.3.4-1247438)
amdgpu-pro : Depends: libgl1-amdgpu-pro-ext (= 21.10-1247438) but it is not going to be installed
              Depends: libgl1-amdgpu-pro-dri (= 21.10-1247438) but it is not going to be installed
amdgpu-pro-lib32 : Depends: libgl1-amdgpu-pro-glx:i386 (= 21.10-1247438)
                    Depends: libegl1-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libgles2-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libglapi1-amdgpu-pro:i386 (= 21.10-1247438)
                    Depends: libgl1-amdgpu-pro-dri:i386 (= 21.10-1247438)
vulkan-amdgpu-pro : Depends: libgcc-s1 (>= 3.3.1) but it is not installable
vulkan-amdgpu-pro:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable
                          Depends: libgcc-s1:i386 (>= 3.3.1) but it is not installable
                          Depends: libstdc++6:i386 (>= 4.9) but it is not installable
                          Depends: libwayland-client0:i386 but it is not installable
I may have figured it out, was not aware that there is an option for the install to disable i386
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!