[SOLVED] AMD (3dnow) Processor emulation? Intel CPU on host.

effgee

Renowned Member
Jul 29, 2013
45
15
73
I have an old appliance (PBX system) that runs on an embedded system, AMD something

https://www.pcengines.ch/alix2d3.htm

My Proxmox host is Intel(R) Xeon(R) CPU L5640.
I have imaged the boot disk and tried to boot the embedded system, and the embedded kernel complains there is no 3d now support on the cpu. I have tried to switch to various CPU profiles (Athlon/Phenom etc) but Proxmox complains the host doesn't support those features.

Is there any way to emulate a few processor features such as 3dnow, I'm not worried about speed of the emulation at the moment, just getting it booting, if I can figure it out I will recompile the kernel for it.

I would like to completely virtualize this box but I need to poke around at the internals in a vm for a bit.

I have seen a few patches here and there to emulate 3dnow etc but I have no idea how to enable this on Proxmox or if they are included or not. Thank you.
 
Nevermind, figured it out!

Solution:
Untick KVM Hardware virtualization and then the processor itself is emulated as well! :)
The image booted mostly.
 
  • Like
Reactions: cjones

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!