After upgrading from Proxmox 7 to Proxmox 8, my VM with macOS Ventura no longer functions

HanzFranz1

New Member
May 27, 2022
16
0
1
After upgrading from Proxmox 7 to Proxmox 8, my VM with macOS Ventura no longer functions. I had a working system with PCI passthrough, passing through an AMD graphics card and a PCI USB3 card. This setup was working fine until the upgrade to Proxmox 8, after which I encountered a boot loop.

Opencore still starts and selects the correct partition for booting. I can see the boot process in verbose mode, but then the process restarts. Do you have any tips on what settings I need to change in the VM configuration?
 
Hello,

do you use these kernel parameters on your host?
"clocksource=tsc tsc=reliable"
This fixed most of the issues I had with MacOS Virtualization.

Does this also happen when not using PCI pass through?
 
I have now tried these settings, but unfortunately, nothing changes. When I remove the passed-through hardware, Ventura starts successfully.

Has anyone successfully run macOS Ventura with PCI passthrough on Proxmox 8?
 
I have no experience with this, but try setting the Machine Version back to 7.2 instead of Latest? Maybe the OS does not like virtual hardware changes.
 
Unfortunately, that doesn't change anything either. But now I've tried further.
The PCI USB card can be passed through. Only when I pass the graphics card does the VM no longer start. The graphics card settings are the same as in proxmox 7. It therefore seems certain to me that something must have changed here after the update to proxmox 8 and therefore maxos no longer starts.
 
Could you maybe provide your vm config?
Code:
qm config [vmid]
 
Here is my config.


args: -device isa-applesmc,osk="ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc" -smbios type=2 -device usb-kbd,bus=ehci.0,port=2 -global nec-usb-xhci.msi=off -global ICH9-LPC.acpi-pci-hotplug-with-bridge-support=off -cpu host,vendor=GenuineIntel,+invtsc,+hypervisor,kvm=on,vmware-cpuid-freq=on


bios: ovmf


boot: order=virtio1;net0


cores: 8


cpu: host


description: Venura


efidisk0: local-lvm:vm-1302-disk-0,efitype=4m,size=4M


hostpci0: 0000:01:00,x-vga=1


hostpci1: 0000:05:00


hostpci2: 0000:04:00,pcie=1


hostpci3: 0000:00:14,pcie=1


machine: q35


memory: 16384


meta: creation-qemu=7.1.0,ctime=1670237351


name: MacOsVentura250gb


net0: vmxnet3=1E:22:50:D5:03:B3,bridge=vmbr0,firewall=1


numa: 0


ostype: other


scsihw: virtio-scsi-pci


smbios1: uuid=f0023735-491a-4641-aecb-53f74ac5f198


sockets: 1


tags: mit-gpu


vga: none


virtio1: local-lvm:vm-1302-disk-1,cache=unsafe,iothread=1,size=250G


vmgenid: 48d2ccb1-eb45-4ea2-bbde-97c199f0ef83
 
Do you still have the old 5.15 kernel from pve7?
You could try booting the old kernel and see if anything changes.
And like @leesteken said you could change the machine version to 7.2.
 
I have already changed the type to 7.2. Unfortunately that doesn't help.

How do I boot into the old kernel?

I have 1 SSD with proxmox 7 on which I updated to version 8.
I freshly installed proxmox 8 on another SSD and restored a backup of the macos Ventura VM. Ventura will not start on either system.

On a 3rd SSD I have the old proxmox 7 version on which everything works.
 
On the ssd where you have made the upgrade, you should still have the old kernels if you did not remove them.
Usually you can select the old kernel in the grub/systemd-boot menu under "advanced options".
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!