Adding BOXNUC6CAYH Wifi/BT drivers

New Member
Feb 26, 2019
Whitby, Ontario
Intel Wifi Drivers not present, and I have no idea how to enable the Wifi module (on-board)

I am completely new to linux, I have google searched for the last 50 minutes and really only found drivers for Windows. I guess I also found linux drivers, but they need to be compiled so I dunno.

NMCLI reports : Network Controller: Intel Corporation Device 24fb (rev 10).

Where do I go from here?

I am assuming this will likely be an easy question for experienced users?

Thank you in advance.

Proxmox does not include the firmware. This package conflicts and can't be installed as is, you need to unpack (dpkg -x) it and copy it to the right directory.
Yes, Alwin is right. It has package conflicts. You should definitely checkout that Debian Wiki guide for WiFi
I really appreciate the responses. I am completed new to linux so I'll do the required reading.

Stuck at Fatal Error: iwlwifi is in use:

# modprobe -r iwlwifi ; modprobe iwlwifi
generates this warning
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!

W: (pve-apt-hook) touch '/please-remove-proxmox-ve'

Should I do this?

E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

Will I lose my current VMs?
Last edited:
Ok, I removed proxmox-ve and installed the iwlwifi driver. Following the instructions (using pve > shell) I ran in to the same error as below, and followed these instructions to overcome. It really feels like this is a lot to get an Internal Wifi driver working.

My USB RALINK card was USB plug and play and easily passed hardware from HOST to VM.

I know this is an older post but I figured I would post a temporary, possibly dangerous solution since it might circumvent dependencies. I got this error when I downgraded proxmox-ve then tried to re-upgrade it at a later date. This likely applies to anyone having issues related to:
/bin/sh: 1: /usr/share/proxmox-ve/pve-apt-hook: not found
Which I believe is related to this patch regarding the addition of a hook script to prevent users from messing with conflicting dependencies (which I suppose I am doing, so do this at your own risk o_O).
I simply created the file pve-apt-hook by executing the command
# mkdir /usr/share/proxmox-ve
# nano /usr/share/proxmox-ve/pve-apt-hook
I wrote empty lines to the script, then saved it with ctrl+o ctrl+x. I then made it executable with
chmod u+x /usr/share/proxmox-ve/pve-apt-hook
Then re-installed proxmox-ve with
apt install proxmox-ve
and it worked. I then removed the hook file when I was done. Hope this helps somebody.
I ran iwconfig and I now see wlp2s0 driver available. How to I make this adapter available to my VM?
* The VM will continue to connect via Ethernet, but will create a Hotspot on demand using Wifi.

Thank you.
as you already write - this is a bit problematic and will most likely lead to broken dependencies.

An alternative would have been to unpack the debian-package for the iwl-firmware and place the firmware file in '/lib/firmware'


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!