Adding a node to existing cluster


Well-Known Member
Jan 6, 2014
root@cfPM5:~# pvecm status
Corosync config '/etc/pve/corosync.conf' does not exist - is this node part of a cluster?
Cannot initialize CMAP service
root@cfPM5:~# pvecm add
detected the following error(s):
* this host already contains virtual guests
Check if node may join a cluster failed!

I tried to copy the corosync.conf from the managing node to no avail.

I tried the following as well:
root@cfPM5:~# systemctl start pve-ha-lrm
root@cfPM5:~# systemctl start pve-ha-crm

I also tried this
systemctl stop pve-cluster
systemctl stop corosync
pmxcfs -l
rm /etc/pve/corosync.conf
rm -r /etc/corosync/*
killall pmxcfs
systemctl start pve-cluster

I am not sure why this is saying this, This node does not have any VMs on it it is a new node and shouldn't have anything at all. I am not understanding why this is happening. How do I fix this via cli without having to re-install?

Thanks in advance,
Did you execute the "pvecm add" command on the node you want to add?

Check our docs if you are unsure. Adding new nodes definitely shouldn't require messing with services or corosync configs (in a basic scenario).
I'm facing a similar problem that already has been posted before but no solution is found.

In my case, on a freshly installed Proxmox v6, with only hostname and /etc/hosts configured i get this.

root@sandyhooks:~# pvecm add
detected the following error(s):
* local node address: cannot use IP '', it must be configured exactly once on local node!

Check if node may join a cluster failed!

I have no idea why but the truth is that I am not able to join another node to an existing cluster (having 3 nodes).
Can you post the output of "ip a", preferrably on both the node you want to add and the cluster node?

Edit: @zacaro I just saw your other post (by accident), it seems you are trying to achieve a cluster over OpenVPN? If so, I recommend opening a seperate thread, as your issue is most likely different from the one posed here.
Last edited:
No problem, my cluster is now working and I've been able to add the new node the only thing I had to do is to edit /usr/share/perl5/PVE/ and commented out the lines 1811 to 1838. That way the system won't check the ip configured and the node joined the cluster smoothly. Then I reverted that change to its original state. So solved, but still not understanding what that check is intended for, in my case only to prevent the addition of a new node in a cluster over OpenVPN.
Hi. This error was resolved by changing in /etc/network/interfaces FROM "iface eno1 inet dhcp" TO "iface eno1 inet static"
*eno1 = interface name


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!