add QNAP NAS to Proxmox Server

vikozo

Active Member
May 4, 2014
684
22
38
suisse
www.wombat.ch
Hello
i have a Proxmox Server and a old QNAP NAS 2x 2TB.
to Backup the Proxmox Virtuell Server i wished to add the QNAP to the storage

i followed
https://pve.proxmox.com/wiki/Storag...MBa.29_share_on_Proxmox_VE_via_.2Fetc.2Ffstab

and have some questions

nano /etc/fstab

//windows-or-samba-server-name/sharename /mnt/samba1 cifs username=yourusername,password=yoursecretpassword,domain=yourdomainname 0 0


a) cifs is not active on the server i changed it to ext3, is it OK?
b) what is the meaning of domain=yourdomainname?
c) what is the meaning of the two 00 at the end?

Is there a way to find out the exact Name of the path, i have added it on Proxmox but i can't find out the right path?

if i do a mount -a i got a
mount: special device //10.147.42.31/bkp_proxmox does not exist

have a nice day
vinc
 

pirateghost

Member
Apr 25, 2013
454
10
18
cifs is not active on the server i changed it to ext3, is it OK?
you can't connect to ext3. cifs is the term used interchangeably for SAMBA share. ext3 is a filesystem, and cifs/smb/samba is a file sharing network protocol. completely different things. you NEED to use cifs to connect to a samba share.

what is the meaning of domain=yourdomainname?
you probably do not need the domain name. if it complains about needing it use domain=WORKGROUP
 

pirateghost

Member
Apr 25, 2013
454
10
18
@pirateghost
Thanks for your feedback.
sad to read so i can't use my QNAP for Backup purpose!

have a nice day
vinc
WHAT?

The QNAP doesn't have iSCSI, CIFS/SAMBA, or NFS?!!

WTF kind of NAS doesn't operate the most basic of NAS functions? How do you access files on it?
 

vikozo

Active Member
May 4, 2014
684
22
38
suisse
www.wombat.ch
@pirateghost
sorry, they (iSCSI, CIFS/SAMBA, or NFS) are inactive because I switched them off :oops:
so I will have to greate a user on the NAS and the same user on Proxmox to give the right to communicate?

@elurex
it sound good what you wrote, I belive my old QNAP TS-212 / 2 x 2TB

will not work



 

vikozo

Active Member
May 4, 2014
684
22
38
suisse
www.wombat.ch
Hello

i have added a share (File Station) on my QNAP TS-212 (192.168.14.31)
Network Service i acitvated WIN/MAC/NFS (NFS-v2/v3 are active)

on Proxomx
i go Datacenter - Storage - Add
select NFS
enter ID: Storage-01
Server: 192.168.14.31
then with Export i see the Available Share
content:Backup
Nodes: nothing
Enable: tick
Max Backups 7

then on the left the Storage is added
when i Click on this i see Summary: Enabled yes, Active No
when i go to content i got a popup with [mount error: mount.nfs: Protocol not supported (500)]

so what i do wrong?

have a nice day
vinc
 

ox1de

New Member
Feb 12, 2016
4
0
1
33
You gave permission suitable hosts to a folder on NFS service ?

WlQz5VB.png
 

nasenmann72

Active Member
Dec 9, 2008
70
1
28
Germany, Saarland
Hi vikozo,

like ox1de said, you have to configure your NFS share with the right permissions. I do not have a QNAP NAS here but I can give you an example like this looks like in OpenMediaVault (Open Source NAS). See the screenshot. You have to set permissions for the network (or host) address of your LAN. In your case it should be 192.168.14.0/24.

upload_2016-2-12_11-35-17.png
 

Attachments

  • upload_2016-2-12_11-35-4.png
    upload_2016-2-12_11-35-4.png
    19.5 KB · Views: 21

vikozo

Active Member
May 4, 2014
684
22
38
suisse
www.wombat.ch
Hello
Thanks for your Help
but no - same error in QNAP i have a directory and a User which have read/writte right
in Proxmox i added the user too
in Proxmox i connect the drive - able to select the drive and save.
But after saving i still have a

mount error:mount.nfs: protocol not supported (500)


on the Qnap NFS-v2*v3 ist aktiv

there is just a final point
in Proxmox i have added the Storage / there are some Permision to add i select the user but which Role would be adequated?

have a nice day
vinc
 

mjw

New Member
Jan 5, 2016
21
3
3
45
Hi!
This sounds similar to the problem I've had.
NFS (at least before v4) does not support permissions based on users. Also your error does not sound like a permission problem. Please check:
a) NFS is enabled on your NAS (Control Panel -> Network Services -> Win/Mac/NFS -> Enable NFS)
b) Allow your PVE Host to access the Folder (Privilege Settings -> Shared Folders -> Permissions of Folder in question -> Permission Type: NFS Host Access -> Add your PVE Host IP -> choose "no_root_squash")
c) go to your PVE Manager and add the Storage

At least for me it works that way.
Good luck. :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!