[SOLVED] activate chrony, its disabled and masked

pille99

Active Member
Sep 14, 2022
360
25
28
hello all

i prepare the upgrade to proxmox 8 and run the script pve7to8.

the result of the test script:

INFO: Checking for supported & active NTP service..
WARN: systemd-timesyncd is not the best choice for time-keeping on servers, due to only applying updates on boot.
While not necessary for the upgrade it's recommended to use one of:
* chrony (Default in new Proxmox VE installations)
* ntpsec
* openntpd

in system on the node is Chronyd Status disabled and unit is masked.
a while ago i tried to solve it but it was not that important to me. but i also couldnt find some solution

root@hvirt04:~# systemctl status chronyd
● chronyd.service
Loaded: masked (Reason: Unit chronyd.service is masked.)
Active: inactive (dead)


any ideas ?
 
hello all

i prepare the upgrade to proxmox 8 and run the script pve7to8.

the result of the test script:

INFO: Checking for supported & active NTP service..
WARN: systemd-timesyncd is not the best choice for time-keeping on servers, due to only applying updates on boot.
While not necessary for the upgrade it's recommended to use one of:
* chrony (Default in new Proxmox VE installations)
* ntpsec
* openntpd

in system on the node is Chronyd Status disabled and unit is masked.
a while ago i tried to solve it but it was not that important to me. but i also couldnt find some solution

root@hvirt04:~# systemctl status chronyd
● chronyd.service
Loaded: masked (Reason: Unit chronyd.service is masked.)
Active: inactive (dead)


any ideas ?
Hi,
you want the chrony ntp client service: stop and disable the systemd-timesyncd service by running systemctl disable --now systemd-timesyncd.service and start and enable chrony via systemctl enable --now chrony.service
 
the result

root@hvirt04:~# systemctl enable --now chrony.service
Synchronizing state of chrony.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable chrony
Failed to enable unit: Unit file /etc/systemd/system/chrony.service is masked.


what is "Service is masked" ?
 
the result

root@hvirt04:~# systemctl enable --now chrony.service
Synchronizing state of chrony.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable chrony
Failed to enable unit: Unit file /etc/systemd/system/chrony.service is masked.


what is "Service is masked" ?
If the service is masked, you can unmask it by running systemctl unmask chorny.service and then start and enable it via the commands mentioned above.
 
chronyd was not installed. i though it will be installed since version 7.xxx, as preperation for migration.
hmm. anyway. its solved
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!