[SOLVED] ACME to Namesilo DNS validation task fails immediately, setpriv exit code 1

SteveITS

Renowned Member
Feb 6, 2025
887
378
68
Task "Order Certificate" fails, with output:


Code:
Loading ACME account details
Placing ACME order
Order URL: https://acme-v02.api.letsencrypt.org/acme/order/310###32/52###376

Getting authorization details from 'https://acme-v02.api.letsencrypt.org/acme/authz/310###32/729###816'
The validation for host.example.net is pending!
[Fri Jul  3 12:06:26 CDT 2026] Unable to add the DNS record.
[Fri Jul  3 12:06:26 CDT 2026] Error add txt for domain:_acme-challenge.host.example.net
TASK ERROR: command 'setpriv --reuid nobody --regid nogroup --clear-groups --reset-env -- /bin/bash /usr/share/proxmox-acme/proxmox-acme setup namesilo host.example.net' failed: exit code 1


The certs successfully ordered in February, successfully renewed on April 29, but the renewal June 28+ is failing each day on all servers.

Notably, a 900s DNS timeout is configured and the task fails immediately in the GUI.

Updated PVE 9.2.2 to 9.2.3, no change.

I tried changing two script _debug lines to _info, same output.

If I run the setpriv command directly, it just waits and does not fail.

I've read several other threads for this error and do not seem to be getting anywhere...help?
 
I triggered a cert elsewhere, and the log there shows:

Code:
response='<?xml version="1.0"?>
<namesilo><request><operation>dnsAddRecord</operation><ip>x.x.x.x</ip></request><reply><code>280</code><detail>Maximum of 100 DNS records per domain has been reached</detail></reply></namesilo>'

So it seems they quietly introduced a limit. :(
 
Just to follow up on this, for posterity, Namesilo has increased their record limits:
  • Free: 100, but “can be increased to 150–300 records upon request”
  • Premium ($9/yr): 500

Creation works, however, record removal fails and this is logged:
Code:
Sleeping 120 seconds to wait for TXT record propagation
Triggering validation
Sleeping for 5 seconds
Status is 'valid', domain 'node.example.com' OK!
sed: -e expression #1, char 48: unknown option to `s'
sed: -e expression #1, char 42: unknown option to `s'
[Sat Sep 19 12:00:10 CDT 2026] Empty record id, it seems no such record.
Remove TXT record: _acme-challenge.node.example.com
TASK ERROR: validating challenge 'https://acme-v02.api.letsencrypt.org/acme/authz/####/####' failed - status: invalid