About idle CPU utilization on windows 11

bellocarico

Member
Sep 17, 2022
43
2
8
I'll try to keep this as short as possible but some historical context is needed to explain what my issue is and what I incidentally discovered.

For months (since installation really) I had both my servers on Proxmox v7 with one Windows11 VM each. Both VMs are installed with the qemu agent (9th Jan 2023 release) and both using about 20-24% of CPU while idle. CPU seen from the Proxmox side, not via task manager.

This week I performed in order:
- upgraded of the qemu agent to 19th Sept 2023 release
- upgraded of proxmox from 7 to 8
- after reading up on windows cpu usage in idling: changed VM type from win11 to Other

Result:
- Server 1 the upgrade didn't work (same identical server HW as Server2) I could however notice that with the VM type Other the CPU for the Win11 VM went town where it's expected to be while idling so 3-5%, the other server that up
- Server 2: the upgrade was completed successfully the Win11 VM CPU stayed at 20-24% despite the VM type change to Other.

I have tried to fiddle further with Server 2's Win11 VM parameters but I could just not bring down the CPU like on Server 1.

Incidentally this morning I have fixed the upgrade issue on Server 1 and went fully to v8 (befofe it was a partial upgrade only). As soon as this was completed the Win11 VM reported CPU went back to 20% idling :-(
1695561239547.png
That's pretty much where I am now. Unable to bring down the CPU usage for Windows 11 VMs under 20% despite the fact that they do absolutely nothing.

Admittedly the HW is old but the fact that I was able to fix this on v7 somehow makes me hope I'm just missing something minor.

Any tip/help please?
Thanks
 
Last edited:
I'm progressing on this topic:

For Windows VM it helps to add the -no-hpet after args: in the $VM.conf this brought down the usage to about 0-10%
1697099000347.png


however I'm expecting this to be even lower... like 3% or something as it used to be long time ago. Out of all the reading I did on this topic I tried but with no visible result to switch the chipset to i440fx and disabled all the unused USB root from within the OS.

I also tried all the CPU on a single socket (I have a dual CPU motherboard) and also the CPU type: kvm64. These operations specifically changes nothing in terms on CPU usage.

There's certainly still something missing here, but I really would like to bring this down to where it was before. Anything else I could try please?

Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!