[SOLVED] 8006 UI cannot be accessed and HTTP error 500 occured


Feb 28, 2018
Hello ,

I faced a problem that the 8006 port cannot access, and I found there is HTTP 500 via the log.
I have tried to restart it (sudo pveproxy restart) but it still HTTP 500, I am not sure how to check what is this error - - [15/10/2019:15:37:39 +0800] "GET / HTTP/1.1" 500 - - - [15/10/2019:16:07:44 +0800] "GET / HTTP/1.1" 500 - - - [15/10/2019:16:14:03 +0800] "GET / HTTP/1.1" 500 - - - [15/10/2019:16:14:08 +0800] "GET / HTTP/1.1" 500 - - - [15/10/2019:16:14:13 +0800] "GET / HTTP/1.1" 500 -

Would you please advisehow can i check/solve this?
check the journal for messages which might indicate where the problem is - e.g. run `journalctl -f` while trying to access the GUI

I hope this helps!
Hello Stoiko,

Thank you, it shows this:

Oct 15 16:25:14 pe1 pveproxy[4996]: Can't locate object method "set_request_host" via package "PVE::RPCEnvironment" at /usr/share/perl5/PVE/APIServer/AnyEvent.pm line 1206.
Oct 15 16:25:19 pe1 pveproxy[4996]: problem with client; Connection timed out

Would you please advise how can i solve this?
Seems there is a mismatch of installed packages - please post the output of `pveversion -v`
and make sure that you have the metapackage 'proxmox-ve' installed correctly


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!