3 Hours boot time


New Member
Aug 4, 2023
So I have been playing around with proxmox on my old pc, trying to setup home NAS for a few weeks now. All hardware was working just fine (only thing I couldn't get to work is IOMMU because of BIOS problems), whole boot was taking around 2-5 minutes. Few days ago I got an extra NVME SSD, so I've decided to replace old system HDD. MOBO (ASUS X58 Sabertooth) doesn't have m.2 slot so I had to use PCIe adapter, and even then legacy BIOS couldn't detect it. Then I've tried CLOVER Bootloader to boot from the SSD but also couldn't get it to work properly. Later I found the Modded BIOS which got NVMe boot support, although when I tried to boot Proxmox, GRUB loading took around 5 minutes and after that line "Loading Linux 6.2.16-3-pve" just hang on for indefinetly. So I've decided to leave it booting for the night. In the morning I saw the pve running, although boot time ("Loading Linux 6.2.16-3-pve" stage to complete boot) took around 3 hours. I already spent day searching online and trying to fix the problem but still no luck((

Thats my first post here, so I apologize if its too long:)

attached file is journalctl log


  • log1.txt
    82.1 KB · Views: 4
Last edited:
Figured it out, somehow my gpu was causing the issue! Probably PCIe bandwidth was splitted between slots, i have no clue tbh :D


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!