see https://forum.proxmox.com/threads/proxmox-ve-9-2-21-bcm57412-bnxt_en-network-failure-after-upgrade-to-kernel-7-0-14-20-pve.186749/ for an issue that might be related.
if possible try booting with `pci=notph` (see the linked thread for other...
extract from /etc/network/interfaces :
The bond is attached to vmbr1, which is VLAN-aware and carries several VLAN interfaces including the management network.
I will now test with "pci=notph" added to the kernel command line and collect a new...
Thanks for the logs!
could you try booting with `pci=notph` added to the command-line (might have a detrimental effect on performance)
also - as most logs here (for the broadcom nics) look like the NICs are in a bond - which bond-mode is used...
could you (and others affected):
* share the journal from booting up the machine until the issue occurred
* try disabling some offloading functionality: `ethtool -K <nic> rx-gro-hw off lro off`
Wurde seinerzeit nicht implementiert - koennte aber hinzugefuegt werden - bitte einen enhancement-request (auf Englisch) unter https://bugzilla.proxmox.com dafuer erstellen
Danke!
I know that this is for a slight different model network adapter, however this may be useful:
https://forum.proxmox.com/threads/proxmox-ve-9-2-21-bcm57412-bnxt_en-network-failure-after-upgrade-to-kernel-7-0-14-20-pve.186749/
In that thread, the...
Hi Stoiko.
I am sorry fo late answer, I would like to have some time to tests. First of all, blacklist works again. I created three new records for my internal tests and after some time I discovered, PMG start to block all records again...
Hello Stoiko,
Thank you for your analysis.
I checked the Dell support site and upgraded the Broadcom BCM57412 firmware to the latest version available from Dell.
After the firmware update, I pinned the previously failing kernel (7.0.14-20-pve)...
Thanks for confirming this! - gives us a pointer if someone else runs into issues with newer Dell Servers!
If your system runs fine as is - I'd leave it there - but in case a future kernel does not boot cleanly - I'd check those settings
Hm - the failing boot does not only fail with the NIC - I also see disk-errors in the journal:
on a hunch - could you check the BIOS for SR-IOV global and I/OAT DMA - see:
https://pve.proxmox.com/wiki/Roadmap#9.1-known-issues
(the issue was...
could you share the journal from a boot where the issue happens, and one where the NICs work?
else - I did not find it right away - but there seems to be a newer firmware version available for the NIC -...
Potentiell ist das ein bug im pmg-log-tracker - bitte einen Report (auf Englisch) unter https://bugzilla.proxmox.com erstellen, damit es nicht uebersehen/vergessen wird.
Danke für das Finden und melden!
* please share `pveversion -v`
* please check (and optionally share) the journal after booting when the system is sluggish for any errors (check if the errors were present when the system was not sluggish as well - then that's likely not the cause)
please share the complete logs of the delivery attempt - from syslog or the journal - and maybe also the redacted mail.
see the reference documentation on the topic...
I would recommend the following (on ThreadReaper)
1. remove the systemd-boot package
2. fill in /etc/default/grub using the one from the working node, but adapt "GRUB_CMDLINE_LINUX_DEFAULT" to get the correct kernel cmdline
3. clear out...