Recent content by NextTime

  1. N

    [SOLVED] Removing messages from the queue older than 1 days

    Привет max046! If for some recipients delivery failed for a transient reason (it might succeed later), the message is placed in the "deferred" queue. Postfix waits for 5 minutes (queue_run_delay, default: 300s ) and checks its deferred queue and then sends again. It complies with the...
  2. N

    [SOLVED] Question about mail queue lifetime

    Hi! You can achieve this by editing the service configuration template main.cf.in Copy the template from /var/lib/pmg/templates/ to /etc/pmg/templates/ then apply your changes there (see details here) To change the default values (5 days) to 6 hours, add the following lines to the end of the...
  3. N

    Problem bei der zustellung

    Hello! You can try to fix DNS records, A and PTR records for this host do not match: nslookup mail.magtech.at 8.8.8.8 Server: dns.google Address: 8.8.8.8 Non-authoritative answer: Name: mail.magtech.at Address: 109.68.107.60 nslookup 109.68.107.58 8.8.8.8 Server: dns.google Address...
  4. N

    No APT repo information for non-root on the web-GUI

    Hi Oguz! I mean I applied this patch locally on my server and can confirm that it works. BR, Aleksei
  5. N

    No APT repo information for non-root on the web-GUI

    Thanks sir, it works (after server restart) Have a nice day!
  6. N

    No APT repo information for non-root on the web-GUI

    Hi there! Has anyone else noticed that a non-root user (even if it's an administrator) has problems accessing repository information in web-GUI of PMG version 7.0? It simply does not appear on the dashboard, and in Administration\Repositories you get a "Permission check failed (403)" error...
  7. N

    Certificate Management behind proxy

    Hi everyone! It's me again with the issues with proxy and ACME certificates. It turned out that my fixes still don't work 100% automatically. To obtain HTTPS certificates, the domains must be validated and the validation is valid for some time. After validation expired you need to validate...
  8. N

    [SOLVED] PMG ACME-DNS with CYON: failing to issue certificate

    Hello! The "Proxmox Mail Gateway Administration Guide" specifically mentions this: See the acme.sh How to use DNS API wiki for more detailed information about getting API credentials for your provider. Configuration values do not need to be quoted with single or double quotes; for some plugins...
  9. N

    Certificate Management behind proxy

    Thanks mate! One extra line of code in both files solved this problem: $ENV{no_proxy} = "localhost"; So now this code looks like this: # setup proxy env my $pmg_cfg = PMG::Config->new(); if (my $http_proxy = $pmg_cfg->get('admin', 'http_proxy')) { $ENV{http_proxy} = $http_proxy...
  10. N

    Certificate Management behind proxy

    One more observation. I do not know if this is somehow related to the change of the certificate, but today I could not install updates from the GUI. In the command prompt everything works as expected: #apt update #apt full-upgrade But if I click the "Upgrade" button I get this error: The...
  11. N

    Certificate Management behind proxy

    Hi Stoiko! Thank you, I hope this helps someone else. As for the variables http_proxy and https_proxy. To keep the server configuration as controllable as possible, I only change configuration via web GUI if possible. So I didn't add manually the proxy address to the file /etc/environment. And...
  12. N

    Certificate Management behind proxy

    Hi guys! I'd like to inform that I managed to make it work (in case anyone else is interested in it). I slightly changed three files and now certificate management through a proxy works both in CLI and GUI. And nothing seems to have broken :) I'm not sure if this is done in the most elegant...
  13. N

    Certificate Management behind proxy

    Continuing my previous post. Considering the fact that I managed to register an ACME account through a proxy using a small workaround in the CLI, I hoped to order the SSL certificate for our server in the same way. But unfortunately this time the same workaround doesn't work. The script does not...
  14. N

    Certificate Management behind proxy

    Hi there! Our PMG server is running in a DMZ with limited Internet access (behind outbound proxy). We have set this in GUI->Configuration: System->Option->HTTP Proxy: So far, this has not been a problem. Today I tried to set up Let’s Encrypt certificate, but stumbled upon creating an ACME...
  15. N

    How to move from PMG 4 to 5.0

    Hi there! Thanks, it worked. I did everything in the console. BR, Aleksei