[SOLVED] vzdump fails: Backup of VM failed - unable to read file qemu-server.conf'


Mar 4, 2018

I'm started to get the following issue recently. Before it worked and for some reasons got broken.

root@px:~# vzdump 117 -dumpdir . -tmp .
INFO: starting new backup job: vzdump 117 --tmpdir . --dumpdir .
INFO: Starting Backup of VM 117 (qemu)
INFO: status = stopped
INFO: update VM 117: -lock backup
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: creating archive './vzdump-qemu-117-2018_07_06-16_29_23.vma'
INFO: starting kvm to execute backup task
ERROR: unable to read file './vzdumptmp24888/qemu-server.conf'
INFO: aborting backup job
INFO: stopping kvm after backup task
ERROR: Backup of VM 117 failed - unable to read file './vzdumptmp24888/qemu-server.conf'
INFO: Backup job finished with errors
job errors

This particular VM is stopped. I tried to restart it and to backup a running vm, and got the same result. It's PVE/ceph cluster and it's not possible to backup a vm. There's enough free space. Have you seen such problem? I would appreciate any help! Thanks
Answering my own question :)

This works:

vzdump 117 -dumpdir /var/lib/vz/dump/backups -tmpdir /root/

This does not:

vzdump 117 -dumpdir . -tmp .

My version:

# pveversion
pve-manager/3.4-11/6502936f (running kernel: 3.10.0-11-pve)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!