[SOLVED] VNC Authentication problems in cluster

whitehat

New Member
May 18, 2012
7
0
1
Hi! Thank You for the GREAT product! Migrated from XenServer and i'm happy :)
But there is a little problem.
In a cluster of 3 servers:
Code:
pvecm nodesNode  Sts   Inc   Joined               Name
   1   M    184   2012-07-24 17:09:47  itsec-proxmox1
   2   M    188   2012-07-24 17:10:08  itsec-proxmox2
   3   M    240   2012-07-25 10:49:33  itsec-proxmox3
When I login to proxmox1 and try to connect to VMs, that are hosted on pm2 and pm3 - I get an authentication error
The same error when trying to connect from pm2 or pm3 to VM's, that are hosted on pm1.
And no problems between pm2 and pm3...
1343212707434.png

All other tasks, like managing pm2 VMs from pm1 - run perfectly
 
Last edited:

whitehat

New Member
May 18, 2012
7
0
1
restarted,
still same error...
Code:
root@itsec-proxmox2:~# tail -f /var/log/syslog
when connecting to pm2 VM from pm1 webadmin:
Code:
Jul 25 14:55:34 itsec-proxmox2 pvedaemon[324039]: authentication failure; rhost= user=root@pam msg=Authentication failure
but when connecting to pm2 VM from pm3 webadmin:
Code:
Jul 25 14:57:31 itsec-proxmox2 pvedaemon[324039]: <root@pam> successful auth for user 'root@pam'
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!