VLAN's across hosts in a cluster

jokeruk

Active Member
Oct 2, 2019
2
0
41
47
Hi All,

I've been banging my head against a brick wall with this one for a while.

I have a homelab with a 2 server cluster. My router (OPNSense) is running on the cluster and is configured to route:

192.168.1.0/24 (no vlan configured) on vmbr0
192.168.10.0/24 (vlan10) on vmbr1
WAN on vmbr3

Now, if I have a server on vlan 10 that's on the same physical server as the router vm, then all is good and I can communicate with it. The issue is when the vlan10 server is on the other host - nothing I seem to do get comms going between the server and the router.

Server 1 interfaces - running opnsense - Any vlan 10 traffic on this server gets routed without issue
Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual

auto eno2
iface eno2 inet manual

iface eno3 inet manual

iface eno4 inet manual

auto ens2f0
iface ens2f0 inet manual

auto ens2f1
iface ens2f1 inet static
        address 10.0.1.52/24
#Cluster traffic - Migration

auto bond0
iface bond0 inet manual
        bond-slaves eno1 eno2
        bond-miimon 100
        bond-mode 802.3ad

auto vmbr0
iface vmbr0 inet static
        address 192.168.1.52/24
        gateway 192.168.1.1
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
#Untagged traffic

auto vmbr1
iface vmbr1 inet manual
        bridge-ports eno3
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
#VLAN traffic

auto vmbr2
iface vmbr2 inet manual
        bridge-ports none
        bridge-stp off
        bridge-fd 0
#Unused

auto vmbr3
iface vmbr3 inet manual
        bridge-ports eno4
        bridge-stp off
        bridge-fd 0
        mtu 1484
#WAN

Server 1 interfaces
Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual

auto eno2
iface eno2 inet manual

auto eno3
iface eno3 inet manual

iface eno4 inet manual

iface ens1 inet manual

iface ens2f0 inet manual

auto ens2f1
iface ens2f1 inet static
        address 10.0.1.25/24
#Cluster traffic - Migration

auto bond0
iface bond0 inet manual
        bond-slaves eno1 eno2
        bond-miimon 100
        bond-mode 802.3ad

auto vmbr0
iface vmbr0 inet static
        address 192.168.1.25/24
        gateway 192.168.1.1
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
#Untagged traffic

auto vmbr1
iface vmbr1 inet manual
        bridge-ports eno3
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
#VLAN traffic

I can migrate a VM that's running on 'server 1' to 'server 2'. If I'm running a ping to the IP address, then the instant it's brought up on server 2, the pings timeout.

Switch is a Cisco 3850 and all relevant ports are set as a trunk (and the bonds are working fine too).

Anyone any thoughts?
 
Switch config is as follows
Code:
interface Port-channel1
 switchport mode trunk
!
interface Port-channel2
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 description "Server1 eno1/2 Bond 0"
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/2
 description "Server1 eno1/2 Bond 0"
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/3
 description "Server1 eno3"
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 description "Server2 eno1/2 Bond 0"
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/6
 description "Server2 eno1/2 Bond 0"
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/7
 description "Server2 eno3"
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 description "Server2 eno4 UNUSED"
 switchport mode trunk
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!