Unable to upgrade - dpkg refuses to install pve-manager

cdukes

Active Member
Sep 11, 2015
88
4
28
Raleigh, NC
www.logzilla.net
As a result of a failed upgrade yesterday, I reinstalled from scratch today and am still getting the same problem.

Code:
Setting up pve-manager (4.0-50) ...
Failed to get D-Bus connection: Unknown error

dpkg audit shows:
#dpkg --audit
Code:
The following packages are only half configured, probably due to problems
configuring them the first time.  The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 pve-manager          The Proxmox Virtual Environment

And, of course, if I try that:

Code:
~# dpkg --configure pve-manager
Setting up pve-manager (4.0-50) ...
Failed to get D-Bus connection: Unknown error -1
Failed to get D-Bus connection: Unknown error -1
dpkg: error processing package pve-manager (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 pve-manager


How can I fix this?
 

Knight

Member
Mar 24, 2014
6
1
23
This is because the system is running Vinit instead of systemd. I run into the same problem because i didn't notice that i have to uninstall the pve* packages before I upgrade to Jessie. Maybe you add this with the link to the wiki into the Announcement?

Try ps -p 1 -o comm=

If this returns initd than you have to change grub to boot the system with systemd.
You can also see this when you execute "systemctl" then the system responds with "Failed to get D-Bus connection: Unknown error -1"

nano /etc/default/grub
Edit the string to the following. Mainly make sure you add "init=/bin/systemd"
GRUB_CMDLINE_LINUX_DEFAULT="quiet init=/bin/systemd"
update-grubcat /boot/grub/grub.cfg
update-initramfs -u
Reboot and try the command above again. If it returns systemd, than you can execute "#apt-get -f install" and the system should finish the installation.
Now proceed with the installation step by step from the wiki pve DOT proxmox DOT com/wiki/Upgrade_from_3.x_to_4.0 or make sure that everything is working as expected.

This resolved my problem. I hope it does the same for you :)

Argh: This site won't work with TLS :(
 
Last edited:
  • Like
Reactions: FuriousGeorge

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!