Hi Forum,
I am new to Proxmox and I am trying to setup a bond using openvswitch with LACP. I cannot get the network up.
I have tried LACP on both HP GUI and Cisco CLI - 2960CS switch. I have very basic config on the switch.
interface Port-channel1
switchport mode access
interface GigabitEthernet0/7
switchport mode access
channel-protocol lacp
channel-group 1 mode active
interface GigabitEthernet0/8
switchport mode access
channel-protocol lacp
channel-group 1 mode active
I have installed openvswitch (2.6.2~pre+git20161223-3) from the Proxmox repo with Proxmox 5.1. I deleted the linux bridge vmbr0 and created a openvswitch vmbr0 using the GUI and rebooted. On my HP Gen8 Microsever (2 NICs) I have the following settings generated via the GUI after the reboot.
auto lo
iface lo inet loopback
iface eno1 inet manual
iface eno2 inet manual
allow-vmbr0 bond0
iface bond0 inet manual
ovs_bonds eno1 eno2
ovs_type OVSBond
ovs_bridge vmbr0
ovs_options lacp=active bond_mode=balance-tcp
auto vmbr0
iface vmbr0 inet static
address 192.168.0.10
netmask 255.255.255.0
gateway 192.168.0.1
ovs_type OVSBridge
ovs_ports bond0
I am unable to ping the network default gateway from the HP server.
If I look at ovs-appctl bond/show bond0. I never see may_enable go true.
---- bond0 ----
bond_mode: balance-tcp
bond may use recirculation: yes, Recirc-ID : 1
bond-hash-basis: 0
updelay: 0 ms
downdelay: 0 ms
next rebalance: 1819 ms
lacp_status: configured
active slave mac: 00:00:00:00:00:00(none)
slave eno1: disabled
may_enable: false
slave eno2: disabled
may_enable: false
Could some one point me to what I have missed? I am at a loss on what I need to do to get this to work.
Thanks
Joshua
I am new to Proxmox and I am trying to setup a bond using openvswitch with LACP. I cannot get the network up.
I have tried LACP on both HP GUI and Cisco CLI - 2960CS switch. I have very basic config on the switch.
interface Port-channel1
switchport mode access
interface GigabitEthernet0/7
switchport mode access
channel-protocol lacp
channel-group 1 mode active
interface GigabitEthernet0/8
switchport mode access
channel-protocol lacp
channel-group 1 mode active
I have installed openvswitch (2.6.2~pre+git20161223-3) from the Proxmox repo with Proxmox 5.1. I deleted the linux bridge vmbr0 and created a openvswitch vmbr0 using the GUI and rebooted. On my HP Gen8 Microsever (2 NICs) I have the following settings generated via the GUI after the reboot.
auto lo
iface lo inet loopback
iface eno1 inet manual
iface eno2 inet manual
allow-vmbr0 bond0
iface bond0 inet manual
ovs_bonds eno1 eno2
ovs_type OVSBond
ovs_bridge vmbr0
ovs_options lacp=active bond_mode=balance-tcp
auto vmbr0
iface vmbr0 inet static
address 192.168.0.10
netmask 255.255.255.0
gateway 192.168.0.1
ovs_type OVSBridge
ovs_ports bond0
I am unable to ping the network default gateway from the HP server.
If I look at ovs-appctl bond/show bond0. I never see may_enable go true.
---- bond0 ----
bond_mode: balance-tcp
bond may use recirculation: yes, Recirc-ID : 1
bond-hash-basis: 0
updelay: 0 ms
downdelay: 0 ms
next rebalance: 1819 ms
lacp_status: configured
active slave mac: 00:00:00:00:00:00(none)
slave eno1: disabled
may_enable: false
slave eno2: disabled
may_enable: false
Could some one point me to what I have missed? I am at a loss on what I need to do to get this to work.
Thanks
Joshua