Remove node from cluster

Hyien

Member
Jun 18, 2021
65
0
6
32
doesn't seem to work. i can still see the node in the UI after following the 'Separate a Node Without Reinstalling'.
 

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,804
319
88
Hi,
doesn't seem to work. i can still see the node in the UI after following the 'Separate a Node Without Reinstalling'.
the node should be inactive now. If it is, you also need to remove the directory /etc/pve/nodes/<nodename>, but I'd first check that there is no configuration you still need in there.
 

nexusguy59

Active Member
Jan 6, 2014
63
12
28
Ohio
www.coopfire.com
You should do a lot of the removal from the master node.

The node you want to remove should be powered down after you run pvecm delnode Node_Name from the master
pvecm nodes
1648478797693.png
mv /etc/pve/nodes/node_name /boot

I think you can run the remove node from the node itself also (but I could be wrong).

Here is a real good article to get you there:
Remove Proxmox Node

I hope this helps,
Michael
 
Last edited:

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,804
319
88
You should do a lot of the removal from the master node.

The node you want to remove should be powered down after you run pvecm delnode Node_Name from the master
It should be powered down before, as the documentation mentions:
At this point, you must power off hp4 and ensure that it will not power on again (in the network) with its current configuration.

pvecm nodes
View attachment 35505
mv /etc/pve/nodes/node_name /boot
Why would you move it to /boot?

I think you can run the remove node from the node itself also (but I could be wrong).
No, it needs to happen from a different node.

Here is a real good article to get you there:
Remove Proxmox Node

I hope this helps,
Michael
 

nexusguy59

Active Member
Jan 6, 2014
63
12
28
Ohio
www.coopfire.com
It should be powered down before, as the documentation mentions:



Why would you move it to /boot?


No, it needs to happen from a different node.
So I have done this few times and if you do it the way the link says to, then it works fine. However if you do not move the /etc/pve/nodes/node_name to somewhere else it will stay in the web gui list of nodes with a red x on it and not remove completely. At least that has been my experience. I am not here to dispute anyone I am just trying to help is all.

Thanks,
 
Last edited:

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,804
319
88
So I have done this few times and if you do it the way the link says to, then it works fine. However if you do not move the /etc/pve/nodes/node_name to somewhere else it will stay in the web gui list of nodes with a red x on it and not remove completely. At least that has been my experience. I am not here to dispute anyone I am just trying to help is all.

Thanks,
Yes, you need to (re)move the directory. But I'm wondering why you move it to /boot, because that's usually not the best place to move unrelated things to ;)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!